Jump to content

Search the Community

Showing results for tags 'GBAGE'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Important Links
    • Serenes Forest Code of Conduct
    • Mistakes or Errors on the Site
  • Important Forums
    • Announcements
    • Member Feedback
    • Site Content
  • General Forums
    • Introductions
    • General
    • Far from the Forest...
    • Creative
    • Fan Projects
    • General Gaming
  • Fire Emblem Forums
    • General Fire Emblem
    • NES and SNES Era
    • GameBoy Advance Era
    • GameCube and Wii Era
    • Nintendo DS Era
    • Nintendo 3DS Era
    • Fire Emblem: Three Houses
    • Fire Emblem Heroes
    • Fire Emblem Warriors
    • Tokyo Mirage Sessions #FE
  • Miscellaneous
    • Forum Graveyard

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Interests


Location

Found 11 results

  1. I would Like to Preface that I'm hacking FE7 and that I have already repointed to Class table So, I've been having some trouble doing exactly what the title says, associating moving map sprites with a custom class, along with a couple of other problem related to custom classes, easily broken down, they are as follows: 1. In nightmare, when I try to add my custom class number to a class list(say, adding 0x65 to the Class List.txt) I find that it shows up in Class editor, and only Class editor, not even Character Editor, which is in the same folder. Am I doing something wrong? and how do I do it properly? 2. Using GBAGE, I have written over the Peer standing and moving animations with my own custom map and moving sprites. The moving sprite went fine, but I had to repoint the standing sprite, does this have any impact on how nightmare associates the peer with it's repointed standing sprite, or no?(as in, does night, mare still point to where the old sprite is, or where I repointed it to using GBAGE when I imported a Bitmap) 3. when I open nightmare(specifically the Class editor) and scroll down to my custom Class (0x65) I notice that there is a option for choosing the standing map sprite of the custom class, but none for choosing the moving map sprites, how should I go about associating the moving sprites with a new class? That should be it for now, I will add more questions relating to this topic whenever I get the chance. Note, Currently, problem number one is the one Im trying to solve the most, as I know ignoring it now will lead to me beating my head against the keyboard at a later date(though that is not to say that my head has not already made contact with the desk multiple times) Thanks in advance!
  2. So after repointed standing map sprite table at 0xb2a610(free space), I inserted a custom map sprite at B2AE10(0x6B). And this happens... It only displays a shadow. I'm sure that map sprite itself works perfectly fine in other games. So I guess it must have something to do with hex. I already changed all these address 26706 2678A 2680C 26C68 27250 27B96 27C82 27D30 27DF0 27E84 27F5A 2804C to FF. But it didn't seem to work. Please help :( Edit: Never mind I figured it out lol Edit:Solution After use Standing map sprite editor in nightmare, open your rom in HxD, go to the address of your repointed table, to the address of that map sprite, you'll find it displays like 02 FF(unknown number) 01 FF(size 16x32) B4 C9 B2 08(graphic address). Change FF to 00 to solve the problem. (Don't know if csv have the same issue though)
  3. Trying to import map sprites from FESS into FE7 and after following Arch's tutorial I managed to get the standing and walking sprites working, but when i move the cursor over the unit it shows some other class's animation (the last unit I moved the cursor over) and I cant figure out why. Screenshots for more details and any help you can give would be amazing, thanks.
  4. I thought I followed Ultimate Tutorial to insert a new background but it messed up pretty bad :( I repointed both the graphic pointer and palette pointer to free space but it still ended up like this. No idea how to solve it. Please help.
  5. So I'm trying to replace the trainee soldier/fighter sprites with Eliwood/Roy respectively. I have their sprites ripped from their respective games, but I have no clue where to go from here. I went to the trainee fighter's pointers in Nightmare, and replaced the standing sprite with Roy's in GBAGE, but nothing has changed. I've also replaced the trainee soldier's standing sprite with Eliwood's, but again, no dice. Also, if anybody could point me in the direction of a tutorial on how to change their names, that would be great. I found a free space at offset 00B8EE10, and inserted Roy's standing animation there using GBAGE. I checked in HxD to make sure that it had been inserted. Then, I went to Nightmare, and repointed the trainee fighter's standing sprite to 0x8B8EE10. I made sure to change the size from 16x32 to 16x16 as well. Now when I load into the game, it just resets the ROM.
  6. Does anybody now of a easy way to edit the CGs that appear in the Lyn Mode Ending? (I want to replace them with plain black images) I also want to replace the "Three Years Later" screen. Editing the Eliwood Mode CGs seems easy enough, but I couldn't figure out how to edit the Lyn mode ones using GBAGE. The Ultimate Tutorial didn't help either... I just go to the offset in the CG editor module and there seems to be nothing there. Can anyone explain to me how to do it?
  7. Ok, I know the title is rather vague, so I'll explain it here. I read up on the GBAGE stuff in Blazer's tutorial and I fixed up the title background, Image 1369, to what I wanted it to be. That worked exactly as I wanted it to, fortunately. Now, I want to edit the text at the bottom, which is at Image 1371. Except I have no idea what the dimensions are for that one. I spent about fifteen minutes trying different sizes, but none of them have seemed to work. How do I find out the dimensions of that image? Is there a Nightmare Module that I can reference to like with all other things or is size just something that I have to keep testing and trying? I looked at the CG editors, Battle Background Editor, and Dialogue Background Editor, but none of them had anything of use for this. Also, what palette does Image 1135 (2003 Nintendo Presents) have? What dimensions?
  8. Hello everyone, I went ahead and made a video showing my issue. It's 2:30 a.m. so I couldn't talk, but I managed to record my mouse pointer: Basically my issue is no matter what I try (changing pointers, re-inserting graphics) the moving sprite for the fighter class is always the big dumb oaf I'm trying to get rid of (seriously, I HATE the default fighters). If anyone knows what's going on any help that is provided will be greatly appreciated. I will also remember to include "[sOLVED]" in my topic title once the issue is resolved. :) Thanks, Gryphon EDIT: I managed to figure it out. Three months back when I was still an uber noob I changed around the text files in the Nightmare module folders. This caused classes in this module to display at the wrong IDs. Fighter is at ID 0x11, not 0x12 like I thought. Thanks to all who took a look at this and tried to help.
  9. So, I've been trying to experiment with some rom hacking programs recently, primarily GBAGE and Event Assembler. I read in Nintenlord's resource thread that I would need Mono to run some of these programs on a non-windows computer (I use a mac). So, I downloaded Mono, and when I use it to start GBAGE up from Terminal, it works perfectly normally. That is, at first. Instead, as soon as I go to the drop-down 'file' menu and click Open Rom, two things happen simultaneously: 1. GBAGE crashes. 2. A bunch of text gets vomited up in Terminal. Event Assembler seems a bit better, except that the exact same thing happens, only later when I click Disassemble after loading a rom and a .txt file. I've tried redownloading, and I end up with the same problem. Any idea what might be causing this? It's probably just some stupid mistake that I made at some point during the installation process, but I can't seem to pinpoint where that mistake was made. Thanks in advance.
  10. Hi everyone. I'm playing a little with backgrounds these days, so I created one and tried to replace the statsheet(and main menu)'s with it: It worked perfectly and I'm pretty happy with the result, however in the statsheet, whenever you scroll up/down or sides, this strange mix of palette appears : This problem also happens in the Status Menu. The Main menu after the title screen and the settings don't have this problem. I tried to find an eventual palette I could've missed using the palette viewer, but when I first scroll the statsheet nothing changes. I can't find this blue that replace the darker color of th background. I checked the image and it's not a transparent color so, while my only clue was this color to be transparent. So yeah, if someone knows how it can be fixed, I would be really greatful to have some help!
  11. How do I make invisible units? In Nightmare, I see how to make units unselectable, and how to remove the standing map sprites, but the unit still appears when the cursor is placed on top of it (to do the "hovering" animation"). Is there somewhere else in Nightmare I can remove that animation too, or does something else need to be done? I know it can be done, because I'm pretty sure it was in one of the Ragefest submissions. Sorry if this is a stupid question and there's a simple solution, but I can't find it.
×
×
  • Create New...