Jump to content
Pia Carrot

Problem with Map in FE7

Recommended Posts

Hi, I'm pretty new to Fire Emblem hacking, however I am not new to ROM Hacking. Today I re-created the first map from the first Fire Emblem game in mappy, and inserted it, although I've run into some problems with the final product.

In game, the map is a disaster:

1d16a3a28f66df49206ffd3c640f3d8a.png

Here is the map in mappy:

2541a9477e585b2ddf56a380dee8ef14.png

Here is the chapter data:

80312600b37b9b9189df80203c78d0e6.png

If anyone has an idea of what the heck is going on, I'd love to know, this is driving me nuts!

Edited by Pia Carrot

Share this post


Link to post
Share on other sites

expand the right window in mappy (fullscreen the entire application, then expand the window with the tileset in it normally)

is it a square, or are there tiles missing from the bottom row (there should be no more than one missing)?

at a glance i would guess that you hit ctrl-x while working at some point

Edited by CT075

Share this post


Link to post
Share on other sites

expand the right window in mappy (fullscreen the entire application, then expand the window with the tileset in it normally)

is it a square, or are there tiles missing from the bottom row (there should be no more than one missing)?

at a glance i would guess that you hit ctrl-x while working at some point

I assume you mean like this:

36c27eac4ae463d90b4c157734f5aae0.png

Not sure what you mean by this: "is it a square, or are there tiles missing from the bottom row (there should be no more than one missing)?"

Share this post


Link to post
Share on other sites

ok i was wrong

describe exactly how you inserted the map (double check that you set the tileset in the chapter data while you're at it)

Share this post


Link to post
Share on other sites

I've followed both chapter 48 here: http://www.feshrine.net/ultimatetutorial/

And this video to a tee:

I've read each step thoroughly, I have no idea why this is happening. I have tried it in a fresh rom as well and I get the same result.

I am inserting it to 0x01000000, with the pointer 0x09000000, which I believe is where the free space starts.

Edited by Pia Carrot

Share this post


Link to post
Share on other sites

ok i was wrong

describe exactly how you inserted the map (double check that you set the tileset in the chapter data while you're at it)

No, you were right. Look at the tile count, it's out of 1022 when it should be 1023.

4e8a2e234b91dba5cb44726426d7ed62.png

Correct one is on the left. Notice on the right, beginning with the bottom two rows of cliff tiles, everything is off.

Share this post


Link to post
Share on other sites

ah, i didn't even notice that; i was expecting to see the obvious disalignment

Edited by CT075

Share this post


Link to post
Share on other sites

Oh, I see. Is there a way to undo that, or will I have to re-map it?

EDIT: Doesn't look like it. Was able to solve it by changing tilesets and finding the shifted tiles over again, so meh. Atleast I had a guideline.

EDIT2: Even with the map fixed, buildings and armory is still messed up:

26d988547b2d350437d372cbcfe013f5.png

Also note how the houses have green backgrounds. They don't in mappy :s

Edited by Pia Carrot

Share this post


Link to post
Share on other sites

screwing the tileset causes all sorts of errors and i really wouldn't recommend trying to fix it manually unless you're extremely savvy

it'd probably be easier to a) export the map as an image and use a converter to get a fixed FMP/MAR file or b) remap it

Share this post


Link to post
Share on other sites

This isn't advice, but you have nice taste in references. I wish FE1/3-1/11 would got a ADV fan remake.

Edited by sirmola

Share this post


Link to post
Share on other sites

What's so hard about fixing a tileset? Isn't it just a bunch of tile images stored linearly after some metadata about the dimension(s) of said tile images?

Share this post


Link to post
Share on other sites
On 4/15/2014 at 9:35 PM, Pia Carrot said:

Hi, I'm pretty new to Fire Emblem hacking, however I am not new to ROM Hacking. Today I re-created the first map from the first Fire Emblem game in mappy, and inserted it, although I've run into some problems with the final product.

In game, the map is a disaster:

1d16a3a28f66df49206ffd3c640f3d8a.png

Here is the map in mappy:

2541a9477e585b2ddf56a380dee8ef14.png

Here is the chapter data:

80312600b37b9b9189df80203c78d0e6.png

If anyone has an idea of what the heck is going on, I'd love to know, this is driving me nuts!

may i get a png of the map? 

Edited by Isaiah Daniel

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...