Jump to content

Recommended Posts

Hey there guys,

I know that I'm more than likely gonna have to shell out for another copy but I wanted to know if anybody had experienced similar problems and maybe had a solution or two I could try before I drop nearly a hundred dollars on a replacement.

I've gotten to the Endgame of the first portion of Radiant Dawn and at the base I can do just about everything. That is everything except get Edward promoted with a Master Seal. When I try I immediately get a disc read error. There are a couple slight scratches on the disc but it's not all that damaged. I've tried cleaning it a couple different ways and still nothing helps. I can start the chapter and play through it, but I have not been able to get Edward to promote in the field so I haven't been able to check whether or not its just his promotion data that's been corrupted by a scratch or if using the Master Seal has something to do with it. That being said I can and have used a Master Seal on Nolan and he promoted just fine.

So yeah, if anybody has any thoughts let me know.

Share this post


Link to post
Share on other sites

Sorry, but that sounds like your copy got permanently glitched. :( I had a similar issue with my old copy of RD, where every time I tried to have Leonardo attack a Peg knight, the game would give me a similar disc read error. I got lucky and found a brand new one in the local Walmart, but...yeah.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...