Jump to content
Blue Druid

Fire Shell Portrait Inserting error.

Recommended Posts

I am rather embarrassed to ask this, but every time I try to insert a portrait with Feditor Adv, the game refuses to load it, despite the mugs themselves matching all criteria (128x112, 16 colours). I've successfully inserted mugs before, but what baffles me the most is that this only happens in Arch's Fire Shell (Zeta), and I know this because I've inserted the mugs in a clean ROM and they work fine.

To be more specific, the problem is that whenever the game has to load the mug I inserted, it restarts, and this happens with any mug I insert and point it to the character number 0x01, but more recently with 0x1A as well.

Here is what happens (undoctored footage):

https://www.youtube.com/watch?v=tOkqfCsOSS0

(the pirate on the right is 0x01, and the Great Knight is 0x1A)

Can anyone please help me with this one?

Edited by Blue Druid

Share this post


Link to post
Share on other sites

did you:

save with FEditor before inserting?

make sure that you don't have the ROM open with multiple programs at once?

try inserting into a slot?

try dumping+reinserting an old portrait to make sure it isn't your version of FEditor?

try using the dev version of FEditor? or, if you're using the dev version, did you try the older version?

Share this post


Link to post
Share on other sites

did you:

save with FEditor before inserting?

make sure that you don't have the ROM open with multiple programs at once?

try inserting into a slot?

try dumping+reinserting an old portrait to make sure it isn't your version of FEditor?

try using the dev version of FEditor? or, if you're using the dev version, did you try the older version?

I did save before, as I edited text.

I'm almost certain.

I don't know what you mean by that :sweatdrop:

No. I'll try that, but I used the Feditor Adv that came in the Toolbox with FireShell.

Yes, I tried both.

Share this post


Link to post
Share on other sites

no you save before editing text as well

save before doing anything in FEditor. This is not as useless as it sounds

Share this post


Link to post
Share on other sites

Oh. Thankfully I made lots of backups, so I'll try that. But do you mean that, once I open Fedtior, save right away without doing anything?

Edited by Blue Druid

Share this post


Link to post
Share on other sites

Oh ,ok that's good to know. Anyway I tried that with both versions of Feditor, and it didn't work. :/

Edited by Blue Druid

Share this post


Link to post
Share on other sites

Holy shit you got it working? Funny thing is, I inserted it successfully at first, but after adding events and maps and had to re-insert it the problem showed up. Anyway, what exactly did you do? Regular Feditor Adv insertion? In which case, there's something I'm missing...

EDIT: Used an earlier backup I made which had less Feditor edits, saved before doing anything, and I got it working o_o. Why must I make a fool of myself again and again?

Yet again, thank you for you kindness and wisdom CT075.

Edited by Blue Druid

Share this post


Link to post
Share on other sites

I never saved before doing anything in FEditor that wasn't class animation editing, and never got such a problem; I'm quite scared now tho so I'll start doing so lol

also because something tells me the random glitches that have started occurring as of late were due to that. And hell if it's hard to bugfix some shit like that

So thanks for bringing this up, Blue Druid. You shouldn't feel ashamed to bring up problems to the community, y' know. Nobody's judging you anyway.

Edited by Alfred Kamon

Share this post


Link to post
Share on other sites

I never saved before doing anything in FEditor that wasn't class animation editing, and never got such a problem; I'm quite scared now tho so I'll start doing so lol

also because something tells me the random glitches that have started occurring as of late were due to that. And hell if it's hard to bugfix some shit like that

So thanks for bringing this up, Blue Druid. You shouldn't feel ashamed to bring up problems to the community, y' know. Nobody's judging you anyway.

First then!

Anyway, thanks for the encouragement Alfred. I really appreciate it! I'm just embarrassed that I started a topic for something I could've fixed myself if I paid more attention to tutorials! Well at least others can learn, so that's one good thing that came from this.

Moral of the story:

  • Save before doing anything in Feditor Adv.
  • Have loads of backups.
  • You might learn something from the Questions section.

Share this post


Link to post
Share on other sites

It's a side effect of the crummy way FEdito manages its metadata (read: free space). If you save, it effectively "resets" the freespace state (because if you've done edits with anyrhing that isn't FEditor or NM2.0, the checksum is invalid) and ensures it isn't overwriting anything. If you forget to save, the app's assumptions about what's free and what isn't will be wrong.

Share this post


Link to post
Share on other sites

It's a side effect of the crummy way FEdito manages its metadata (read: free space). If you save, it effectively "resets" the freespace state (because if you've done edits with anyrhing that isn't FEditor or NM2.0, the checksum is invalid) and ensures it isn't overwriting anything. If you forget to save, the app's assumptions about what's free and what isn't will be wrong.

Oh, that explains everything. Are there plans to fix this, or is there no reason to fix it as long as you save before editing?

Share this post


Link to post
Share on other sites

There's no simple way to fix it short of rehauling the entire metadata system from scratch. Also, hextator has stopped working on the application anyway (so any update would be community-driven, like Temp's dev build).

Since you asked, though, I suppose that it isn't a secret that I'm working on an overhaul, but that's mostly for compatibility with another project (with any usability upgrades a happy side effect).

Share this post


Link to post
Share on other sites

There's no simple way to fix it short of rehauling the entire metadata system from scratch. Also, hextator has stopped working on the application anyway (so any update would be community-driven, like Temp's dev build).

Since you asked, though, I suppose that it isn't a secret that I'm working on an overhaul, but that's mostly for compatibility with another project (with any usability upgrades a happy side effect).

Well, as long as there's a way to avoid the problem, then there's no reason to make an update I suppose.

And what project is that if I may ask? Don't feel inclined to tell me if it's a secret though.

Share this post


Link to post
Share on other sites

It's not my project per se (I'm involved but I'm not core) so I won't go into detail, but you can find it on FEU if you look up "Suite"; I'd link it but I'm on a phone.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...