Jump to content
Sign in to follow this  
Orange Juice

GBAGE and Event Assembler keep crashing

Recommended Posts

So, I've been trying to experiment with some rom hacking programs recently, primarily GBAGE and Event Assembler. I read in Nintenlord's resource thread that I would need Mono to run some of these programs on a non-windows computer (I use a mac). So, I downloaded Mono, and when I use it to start GBAGE up from Terminal, it works perfectly normally.

That is, at first. Instead, as soon as I go to the drop-down 'file' menu and click Open Rom, two things happen simultaneously:

1. GBAGE crashes.

2. A bunch of text gets vomited up in Terminal.

Event Assembler seems a bit better, except that the exact same thing happens, only later when I click Disassemble after loading a rom and a .txt file. I've tried redownloading, and I end up with the same problem. Any idea what might be causing this? It's probably just some stupid mistake that I made at some point during the installation process, but I can't seem to pinpoint where that mistake was made. Thanks in advance.

Share this post


Link to post
Share on other sites

Okay. I've spoilered it, since it's rather long.

System.NullReferenceException: Object reference not set to an instance of an object
at Nintenlord.ROMHacking.GBA.Compressions.LZ77.CanBeUnCompressed (System.Byte[] data, Int32 offset, Int32 minSize, Int32 maxSize) [0x00000] in <filename unknown>:0
at Nintenlord.ROMHacking.GBA.GBAROM.CanBeLZ77Decompressed (Int32 offset, Int32 maxSize, Int32 minSize) [0x00000] in <filename unknown>:0
at Nintenlord.GBA_Graphics_Editor.Program.Update () [0x00000] in <filename unknown>:0
at Nintenlord.GBA_Graphics_Editor.Forms.MainForm.Refresh () [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control.OnEnabledChanged (System.EventArgs e) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Form.OnEnabledChanged (System.EventArgs e) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control.set_Enabled (Boolean value) [0x00000] in <filename unknown>:0
at (wrapper remoting-invoke-with-check) System.Windows.Forms.Control:set_Enabled (bool)
at System.Windows.Forms.Form.ShowDialog (IWin32Window owner) [0x00000] in <filename unknown>:0
at (wrapper remoting-invoke-with-check) System.Windows.Forms.Form:ShowDialog (System.Windows.Forms.IWin32Window)
at System.Windows.Forms.CommonDialog.ShowDialog (IWin32Window owner) [0x00000] in <filename unknown>:0
at System.Windows.Forms.CommonDialog.ShowDialog () [0x00000] in <filename unknown>:0
at (wrapper remoting-invoke-with-check) System.Windows.Forms.CommonDialog:ShowDialog ()
at Nintenlord.GBA_Graphics_Editor.Forms.MainForm.loadROMToolStripMenuItem_Click (System.Object sender, System.EventArgs e) [0x00000] in <filename unknown>:0
at System.Windows.Forms.ToolStripItem.OnClick (System.EventArgs e) [0x00000] in <filename unknown>:0
at System.Windows.Forms.ToolStripMenuItem.OnClick (System.EventArgs e) [0x00000] in <filename unknown>:0
at System.Windows.Forms.ToolStripMenuItem.HandleClick (Int32 mouse_clicks, System.EventArgs e) [0x00000] in <filename unknown>:0
at System.Windows.Forms.ToolStripItem.FireEvent (System.EventArgs e, ToolStripItemEventType met) [0x00000] in <filename unknown>:0
at (wrapper remoting-invoke-with-check) System.Windows.Forms.ToolStripItem:FireEvent (System.EventArgs,System.Windows.Forms.ToolStripItemEventType)
at System.Windows.Forms.ToolStrip.OnMouseUp (System.Windows.Forms.MouseEventArgs mea) [0x00000] in <filename unknown>:0
at System.Windows.Forms.ToolStripDropDown.OnMouseUp (System.Windows.Forms.MouseEventArgs mea) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control.WmLButtonUp (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.ScrollableControl.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.ToolStrip.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.ToolStripDropDown.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control+ControlWindowTarget.OnMessage (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control+ControlNativeWindow.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.NativeWindow.WndProc (IntPtr hWnd, Msg msg, IntPtr wParam, IntPtr lParam) [0x00000] in <filename unknown>:0
System.NullReferenceException: Object reference not set to an instance of an object
at System.Windows.Forms.ToolStripDropDownMenu.CalculateConnectedArea () [0x00000] in <filename unknown>:0
at System.Windows.Forms.ToolStripDropDownMenu.OnPaintBackground (System.Windows.Forms.PaintEventArgs e) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control.WmPaint (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.ScrollableControl.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.ToolStrip.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.ToolStripDropDown.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control+ControlWindowTarget.OnMessage (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control+ControlNativeWindow.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.NativeWindow.WndProc (IntPtr hWnd, Msg msg, IntPtr wParam, IntPtr lParam) [0x00000] in <filename unknown>:0

Share this post


Link to post
Share on other sites

it's probably because the applications use some kind of form control that doesn't exist in mono

not entirely sure how to fix it unfortunately

Share this post


Link to post
Share on other sites

Short of straight up doing your stuff in a VM (do not do this) or something, you're pretty SOL

sorry

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...