Jump to content
BrightVega

[SOLVED] (FE8) "Naglfar" (or any weapon) to have the Holy/Divine glow/shine?

Recommended Posts

Naglfar doesn't glow since it isn't super effective against anything like a horseslayer

I think he means the bar of light seen when combat involving someone with regalia begins.

Sorry BrightVega, I don't know how to hack/edit/whatever-it-is-you-need, but I'd suggest finding the codes for the other regalia and seeing if they have anything in common. Try Glepnir, as IIRC it is the only actual sacred weapon that doesn't have innate Slayer.

Share this post


Link to post
Share on other sites
Posted (edited) · Hidden by ghast, October 31, 2015 - No reason given
Hidden by ghast, October 31, 2015 - No reason given

sorry for doublepost.

Edited by icecube

Share this post


Link to post

I think he means the bar of light seen when combat involving someone with regalia begins.

Yep, that thing.

Sorry BrightVega, I don't know how to hack/edit/whatever-it-is-you-need, but I'd suggest finding the codes for the other regalia and seeing if they have anything in common. Try Glepnir, as IIRC it is the only actual sacred weapon that doesn't have innate Slayer.

Already done and it's not something in the item table, nor it has do with the effectiveness pointer.

Try this.

"Make sure that these areas are free

B2E900 - B2EC5F

B2F080 - B2F0AC

If those areas are occupied, make sure to repoint all files properly."

How can I repoint them? IPS patcher doesn't ask you where to install them

and opening it in HxD it seems(?) to show multiple offsets(?)

Share this post


Link to post
Share on other sites

He means that the ROM needs to have those spaces open, which they are in vanilla. If you don't see a bunch of FF's, then you've have to move the information there somewhere else before installing the patch.

Share this post


Link to post
Share on other sites

And i thought i could send the patch elsewhere...

*facepalm* I have chapter related stuff and a custom background in there. Should have done/asked that earlier.

Will see how to do it now...

Share this post


Link to post
Share on other sites

I'm assuming that you have free space in B80000

Copy this to 0x58AD2

03 49 40 18 00 78 03 21 08 40 02 BC 08 47 00 00 B8 08

Open New FE8 W Animation Table.nmm, then change 0xB2E900 into 0xB80000.

To reset the table, set B80000 - B800FF in the ROM into 00

Edited by icecube

Share this post


Link to post
Share on other sites

Sorry for the late reply, had to test some things multiple times.

Icecube, your instructions and patch worked and worked fine! Really thx for your help!

It just made 3 things a bit "unstable".

Glitch1: The restore staff sound effect 1/10 times bugs and persist to sound even after the animation finishes. A soft or hard reset each time fixes it.

Glitch2: All animations play without issues

but spellbook "Excalibur" 1/6 times will not show the first part of the animation (the blowing 2 torrents of wind in the start of the animation)

while the wind blades (big and small) that follow after that will play and sound without issues.

This happens against big sized enemies (Wyvern Knights, Draco Zombies and especially Fomortiis) while against small monsters it had no problems.

Glitch3: Just once Myrrh's dragonbreath against a draco zombie froze the game.

Restarting from the suspended data and replaying the exact same battle animation had no problems.

These modules aren't expected to be compatible with other patches.
Using these patches along with other patches messing with battle formula
or animations may causes bugs.

Yeah, i have 2 other patches, one for weapon bonus rank and one for passive stat boosts.

Share this post


Link to post
Share on other sites

Can you post the version before you used my patch?

Yes, sure, I have a copy,

just send you an PM with a link.

Veeeery slow edit/update but here it is:

Started a new game and finished it without any issues at all.

The patch is 100% working without any hiccups and i can confirm it works with the other patches too.

Edited by BrightVega

Share this post


Link to post
Share on other sites

I've examined your ROM.

If using the patch causing glitches, do not use the patch.

Instead, try implementing #8, since no modification has been made in 0x58AD2.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...