Jump to content
luyairis

[Team If] Fire Emblem Fates - Content Restoration (v1.3) (PLEASE READ OP)

Recommended Posts

Thank you SO, SO, SO MUCH for making this patch!! I was wondering if you were going to make a separate patch just for the Saizo and Beruka, and "magic dust" conversations for those of us who like the original dialogue. Thanks again for saving us.

Share this post


Link to post
Share on other sites

I have a few questions about the undub patch (keep in mind that I know NOTHING about 3ds modding/hacking):

1) Is it possible to apply it to the physical copy of the SE edition?

2) I have a new 3ds that is updated to the most recent version, will this still work?

3) If I choose afterwards to update a game/software, go online, or download DLC, will I run the risk of ruining my 3ds?

Edited by jitters

Share this post


Link to post
Share on other sites

I just want to clarify some things-

So you copy the patcher and the zip files onto the SD card, put the card into the 3ds, and it'll patch automatically?

Will the patch be tested before hand?

And this will work on the NA special edition as well?

1. No it's more complicated then that.

2. I don't know.

3. It works on all versions, read the OP please.

Edited by thedude28

Share this post


Link to post
Share on other sites

Thank you SO, SO, SO MUCH for making this patch!! I was wondering if you were going to make a separate patch just for the Saizo and Beruka, and "magic dust" conversations for those of us who like the original dialogue. Thanks again for saving us.

Low priority.

I have a few questions about the undub patch (keep in mind that I know NOTHING about 3ds modding/hacking):

1) Is it possible to apply it to the physical copy of the SE edition?

2) I have a new 3ds that is updated to the most recent version, will this still work?

3) If I choose afterwards to update a game/software, go online, or download DLC, will I run the risk of ruining my 3ds?

1. Yes. Stated so to work with all versions in OP.

2. If you can access Homebrew via several of the methods, all non-dlc content can.

3. Clearly you're using Homebrew, so no, you can't brick it. Several of those may break the patch though.

Edited by luyairis

Share this post


Link to post
Share on other sites

You can, yes. But you'll need to change it back to OoThax every time you want to access Homebrew again, which is a big pain if you play it regularly.

I see. So in summary, I will be able to play and download DLC as it comes out but I won't be able to update my firmware. It's also going to be a pain to backup my game as I'll need to relaunch using OoThax every time I want to play Fates.

Also, can I patch over the hack and then reinstall it or is that just not possible? Thanks once again for answering my questions.

Edited by Arkanus92

Share this post


Link to post
Share on other sites

I see. So in summary, I will be able to play and download DLC as it comes out but I won't be able to update my firmware. It's also going to be a pain to backup my game as I'll need to relaunch using OoThax every time I want to play Fates.

Also, can I patch over the hack and then reinstall it or is that just not possible? Thanks once again for answering my questions.

Yeah that's basically it.

If you want to play the game without the patch just don't use homebrew.

Edited by thedude28

Share this post


Link to post
Share on other sites

You guys are all amazing.

This is my first time playing fire emblem ( I usually hate strategy rpgs) but I'm loving it so much. I tried playing it firstly by using your translation months and months ago. And I got hooked! I myself picked up the SE copy and I'm just so so so happy your project ignited this desire in me and I'm loving fire emblem so much.

Share this post


Link to post
Share on other sites

Hey, thank you all for the work you're putting into this!

I was wondering since you will be releasing a patcher for this, if it is possible to work these patches in with UnassumingVenasaur's Extended Same-Sex Marriage patch and/or DeathChaos25's workaround to getting children from same-sex S-supports?

Also, what is the priority on the Fan-translations to be patched in since I understand they're going through a revamp?

Share this post


Link to post
Share on other sites

@@Cellenseres @@SciresM

Ok so, I'm comparing some data between Accessory shops on NA/JP versions, and here are my notes as I compare the data, the file I'm comparing is GameData/AcceShop.bin after decrypting them with FEAT.

The USA Version has 8 less pointers than the Japanese version, meaning the Accessory Shop in the localized version has 2 less items after accounting for the 8 removed pointers at 4 pointers per item.

Now, for the strings of data Availible in the JPN version but not in the Localized USA Version of this file;

First are the actual IDs for the Accesories;

ACCE_きわどい水着 is not listed in the USA version, according to the localized text, this is the "Bold Swimsuit".

ACCE_草花の水着 is also not listed, according to localization, "Tropical Suit".

Next is the Labels used by the game to identify them, these are the name labels for the above two;

MKID_ACCESHOP_きわどい水着

MKID_ACCESHOP_草花の水着

Next is the description labels for these two;

MKID_H_ACCESHOP_きわどい水着

MKID_H_ACCESHOP_草花の水着

I don't have access to my 3DS for some time, but I imagine using the Japanese version of the file in the localized games could easily work assuming the model data and whatnot is still present in the game.

Edited by DeathChaos25

Share this post


Link to post
Share on other sites

Hi there,

I've been doing Fire Emblem if conversation translations for a while, and I was wondering if I could help out. I work as a pro localizer in Japan, and I can't stand to see the game ripped apart like this.

PM me your Skype!

Hey, thank you all for the work you're putting into this!

I was wondering since you will be releasing a patcher for this, if it is possible to work these patches in with UnassumingVenasaur's Extended Same-Sex Marriage patch and/or DeathChaos25's workaround to getting children from same-sex S-supports?

Also, what is the priority on the Fan-translations to be patched in since I understand they're going through a revamp?

Yes, it's likely possible. We probably won't work on it, but if DeathChaos25 or someone wants to make it compatible, then I don't see why not. Our patcher isn't limited to our files only.

We have all the newer members of the team recently recruited working on supports. The more veteran members of the team are enjoying life instead (we're burnt out).

Share this post


Link to post
Share on other sites

Hey, thank you all for the work you're putting into this!

I was wondering since you will be releasing a patcher for this, if it is possible to work these patches in with UnassumingVenasaur's Extended Same-Sex Marriage patch and/or DeathChaos25's workaround to getting children from same-sex S-supports?

Also, what is the priority on the Fan-translations to be patched in since I understand they're going through a revamp?

They said they'll release it in soon.

Share this post


Link to post
Share on other sites

So you copy the patcher and the zip files onto the SD card, put the card into the 3ds, and it'll patch automatically?

Since most of this post was answered, I'm just going to focus on this question.

The patcher is ONLY for those who are using a flashcart or Custom Firmware. If you aren't using either of those, ignore the patcher.

The zip files are the patch itself, and to use these with a physical copy, you'll need a way to access the Homebrew Menu, either through Ninjahax, OoThax, or Smashhax. Then you'll have to boot the game using the program HANS which comes with most Homebrew Menu data, this program temporarily applies custom patches to games. As I understand it, you'll need to launch the game through HANS every time you play.

Edited by Notius

Share this post


Link to post
Share on other sites

Hello! First of all thank you so much to the team doing this!! It's great to know that japanese voices and amie will be available with this patch.

Now, on to the questions...Sorry if I'm being annoying, I don't have the slightest clue about coding and, well, haha. Here's my situation:

I have an old 3ds and recently bought a new 32 gb sd card because my other 2 were already full with other games. I bought Fire Emblem Fates Birthright on nintendo eshop and it's the only game I currently have on this 32gb sd card. Also, I accidentally upgraded my 3ds to 10.6...With all this info, is it hopeless for me to use the patch? Is there any way I can still use it? Or should I swallow my tears and buy a japanese 3ds? Any help is appreciated. Sorry for the trouble, and thanks!!

Share this post


Link to post
Share on other sites

Hello! First of all thank you so much to the team doing this!! It's great to know that japanese voices and amie will be available with this patch.

Now, on to the questions...Sorry if I'm being annoying, I don't have the slightest clue about coding and, well, haha. Here's my situation:

I have an old 3ds and recently bought a new 32 gb sd card because my other 2 were already full with other games. I bought Fire Emblem Fates Birthright on nintendo eshop and it's the only game I currently have on this 32gb sd card. Also, I accidentally upgraded my 3ds to 10.6...With all this info, is it hopeless for me to use the patch? Is there any way I can still use it? Or should I swallow my tears and buy a japanese 3ds? Any help is appreciated. Sorry for the trouble, and thanks!!

Yeah it's hopeless because you have a digital copy of the game.

Share this post


Link to post
Share on other sites

Yeah it's hopeless because you have a digital copy of the game.

Aww, that's such sad news...well, I guess I'll have to buy a japanese 3ds when I save some money. Thanks for the reply!

Share this post


Link to post
Share on other sites

Aww, that's such sad news...well, I guess I'll have to buy a japanese 3ds when I save some money. Thanks for the reply!

Why would you want a Japanese 3DS when you can just buy the game again and use the patch?

Share this post


Link to post
Share on other sites

Why would you want a Japanese 3DS when you can just buy the game again and use the patch?

But will it work with my 3ds updated to 10.6? I don't want to buy the same game if I'm not sure it'll work with that update.

Share this post


Link to post
Share on other sites

But will it work with my 3ds updated to 10.6? I don't want to buy the same game if I'm not sure it'll work with that update.

You'll need either a Powersaves or someone who can access the Homebrew menu, then you'll need either a copy of Ocarina of Time or Cubic Ninja (I've heard Smash Bros works too, but it's apparently more difficult). With either Powersaves or access to Homebrew, you can add a save to these games that will launch Homebrew when selected.

Share this post


Link to post
Share on other sites

This question might sound redundant but should I wait for the delocalization patch? Or should I just buy the japanese version of the game and just patch that? I got some extra money by chance to pick up maybe a limited edition japanese version.

Share this post


Link to post
Share on other sites

Do remember that the translation currently do not translate support conversations. And the Japanese Limited Edition does not include the 3rd path (Invisible Kingdom) so you'll need access to the JPN shop to be able to download it and do a rather complicated series of things to extract and then patch the said DLC. Plus do remember that you'll need a 3DS with a CFW to use the patched DLC otherwise it will not work as far as I know...

Share this post


Link to post
Share on other sites

Do remember that the translation currently do not translate support conversations. And the Japanese Limited Edition does not include the 3rd path (Invisible Kingdom) so you'll need access to the JPN shop to be able to download it and do a rather complicated series of things to extract and then patch the said DLC. Plus do remember that you'll need a 3DS with a CFW to use the patched DLC otherwise it will not work as far as I know...

Does that really work? Can a CFW patch a digital version of the game and its DLC? Actually, is there even a CFW for New 3DS?

Edit: apparently ReiNand CFW works for N3DS.

Edited by Merik2013

Share this post


Link to post
Share on other sites

You'll need either a Powersaves or someone who can access the Homebrew menu, then you'll need either a copy of Ocarina of Time or Cubic Ninja (I've heard Smash Bros works too, but it's apparently more difficult). With either Powersaves or access to Homebrew, you can add a save to these games that will launch Homebrew when selected.

Hmm, yeah, I guess I'll just save for a japanese 3ds.

Share this post


Link to post
Share on other sites

Does that really work? Can a CFW patch a digital version of the game and its DLC? Actually, is there even a CFW for New 3DS?

Yes to all of it. You can use NTR to patch it. For CFW, the best for New 3DS are either CakesFW or Reinand.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...