Jump to content
ShadySheikah

Fire Emblem If Fan Translation (Under New Management!)

Recommended Posts

Hey, Sheikah. I'm just here to give you a sort of warning in regards to missing files in the patch.

I looked high and low, but I couldn't find the file for the Joker x Felicia support anywhere in the m folder. Methinks it might have been skipped over for some reason (though when I last inspected said file, nothing seemed to be wrong). I'm not sure if this is the only file missing, but I wouldn't be surprised if it wasn't.

I'd check for other missing ones myself, though that would be very time consuming as theres so many, and I'm not really in the mood right now. Consider this a friendly warning to double check when you have the time.

Share this post


Link to post
Share on other sites

Thanks for the heads up! It was a mistake on my end.

I just added the file to the repo and updated the release zip to include Joker x Felicia. If anyone already downloaded the release, you'll can simply download the support here and place the file in the "m" folder of "rom". Of course, if you'd like you can also re-download the zip and it'll be in there.

Hopefully that's the only one missing, but we'll double check just in case!

Share this post


Link to post
Share on other sites

Don't want to sound like a beggar but are chapter summaries on the world map translated or you guys gonna translate them later? I only see Chap 0-4 translated. Thanks again for the hard work. :) 

Edited by TsundereGuyAznMan

Share this post


Link to post
Share on other sites

Sorry about that, the chapter summaries keep getting bumped down the to-do list. But now that we're over the mountain of first-gen supports, we do plan to focus a lot more on the miscellaneous text like My Castle dialogue and system text. Since it's such a small file, I'm guessing we could get the summaries done by the next monthly commit.

Share this post


Link to post
Share on other sites

Hi guys, my patcher doesn't seem to want to really work.

The first image is as far as I get, before the 2nd image gives me an error message.  I ran the program as administrator with the same result.

I am running Windows 10 64 bit Education Edition, with a 4GHz 8-core processor, 16 GB RAM, and a Radeon R9 290x graphics card.

What am I missing here?  I'll gladly post any more information you may need.

Thanks!

1.PNG

2.PNG

Share this post


Link to post
Share on other sites
37 minutes ago, cuddletrousers said:

Hi guys, my patcher doesn't seem to want to really work.

The first image is as far as I get, before the 2nd image gives me an error message.  I ran the program as administrator with the same result.

I am running Windows 10 64 bit Education Edition, with a 4GHz 8-core processor, 16 GB RAM, and a Radeon R9 290x graphics card.

What am I missing here?  I'll gladly post any more information you may need.

Thanks!

1.PNG

2.PNG

Did you decrypt your CIA first?

Share this post


Link to post
Share on other sites
Just now, cuddletrousers said:

I will double check that this is the file I pulled from my cart.  I'm fairly sure, but I will get back to you.

It might very well be, but I'm asking if you decrypted it using GodMode9 or decrypt9 after you dumped it. It has to be decrypted before it can be patched.

Share this post


Link to post
Share on other sites

Okay, since it's been decrypted(with deep decryption I hope), I went ahead and paged ShadySheik with the issue. We'll see if he can get you sorted out when he wakes up.

Edited by Kyonko802

Share this post


Link to post
Share on other sites
46 minutes ago, Kyonko802 said:

Okay, since it's been decrypted(with deep decryption I hope), I went ahead and paged ShadySheik with the issue. We'll see if he can get you sorted out when he wakes up.

Update: Found the problem, guv'.  The CIA I used was from a dump I did a long time ago and was one that was -not- decrypted.  A simple passthrough of GodMode9 solved it, and patch went through with no problems.

Same problem arose with my DLC I bought, so I'm gonna also run -that- through GodMode9 as well.  I'll keep you posted.

Update 2:  DLC was also encrypted, but a run through GodMode fixed it right up.  Out of the files that no patch was available, I found 4 files that had patches available, which makes sense.  I don't think I should have anymore DLC packs that need patching, other than the 4, do I?

TLDR check your files and make sure they're decrypted.  D'oh!

3.PNG

4.PNG

Edited by cuddletrousers
Updates

Share this post


Link to post
Share on other sites

I'm glad you were able to get it to work!

So far it's just those four DLCs, yeah. If/when we end up doing the bonus DLC, we'll just add them to the patch and the program will pick them right up.

Share this post


Link to post
Share on other sites

Hi! Just a few quick questions for future reference, if you own the special edition its safe to skip out on patching the Hoshidan and Nohrian dlc paths right? does it save time? and also just patching one of the Invisible Kingoms

Share this post


Link to post
Share on other sites

I keep getting this error when I try to patch the special edition and I'm not sure why.

Capture.PNG

Share this post


Link to post
Share on other sites
11 hours ago, TheLem said:

I keep getting this error when I try to patch the special edition and I'm not sure why.

Capture.PNG

Try and run it as admin.

18 hours ago, AnyaByakuya said:

Hi! Just a few quick questions for future reference, if you own the special edition its safe to skip out on patching the Hoshidan and Nohrian dlc paths right? does it save time? and also just patching one of the Invisible Kingoms

If you have the special edition, patching the main game and IK should get you everything. I recommend patching both versions of IK. They are both in the games files so who knows what you could break if you ignore half of it?

Share this post


Link to post
Share on other sites

I seem to be having some trouble with this patch. The menu and story text all seems to be translated properly, but for some reason none of the first gen supports or skinship lines are translated. So far, I've tried repatching and reinstalling, running the game with and without the patched dlc, and running the patcher as an administrator. From what I can tell, the files are all present in the rom folder. It almost seems like the patcher just isn't applying certain files. Is there something I can do differently?

Share this post


Link to post
Share on other sites
9 hours ago, Kyonko802 said:

Try and run it as admin.

I tried this and I get the same error.

Share this post


Link to post
Share on other sites
10 hours ago, TheLem said:

I tried this and I get the same error.

Okay, it seems to be almost random.

I ran the patcher and it worked, then Shady ran it again and he got the error even though it had been working before, we'll look into it.

17 hours ago, Bipolarized said:

I seem to be having some trouble with this patch. The menu and story text all seems to be translated properly, but for some reason none of the first gen supports or skinship lines are translated. So far, I've tried repatching and reinstalling, running the game with and without the patched dlc, and running the patcher as an administrator. From what I can tell, the files are all present in the rom folder. It almost seems like the patcher just isn't applying certain files. Is there something I can do differently?

We don't know what could be causing that, but Shady is writing the patcher to check for every file and make sure it's added. Apologies for the inconvenience everyone!

Share this post


Link to post
Share on other sites
17 hours ago, Bipolarized said:

I seem to be having some trouble with this patch. The menu and story text all seems to be translated properly, but for some reason none of the first gen supports or skinship lines are translated. So far, I've tried repatching and reinstalling, running the game with and without the patched dlc, and running the patcher as an administrator. From what I can tell, the files are all present in the rom folder. It almost seems like the patcher just isn't applying certain files. Is there something I can do differently?

That's very odd. The story files are in the same folder as the supports and Skinship files, so if you have those, you should definitely have the rest. Just in case, I ran the patcher on a clean backup and the support files were copied from the patch without problems. Is it possible you have a layeredFS patch running that could override what's in the game? Did you uninstall the previous game completely before re-installing it?

On 6/27/2017 at 6:14 AM, TheLem said:

I keep getting this error when I try to patch the special edition and I'm not sure why.

Capture.PNG

The error indicates the patcher was able to successfully extract and patch the game, but something happened during the rebuilding process. Unfortunately, it's a multi-step process and I'm not able to tell where things might've gone awry from this alone. I just built an updated version of the patcher that should catch errors during rebuild as they occur. If you could download the updated program here and try patching your game again, if something happens the error message will help me narrow down the possible causes.

Share this post


Link to post
Share on other sites
6 hours ago, ShadySheikah said:

That's very odd. The story files are in the same folder as the supports and Skinship files, so if you have those, you should definitely have the rest. Just in case, I ran the patcher on a clean backup and the support files were copied from the patch without problems. Is it possible you have a layeredFS patch running that could override what's in the game? Did you uninstall the previous game completely before re-installing it?

That might be the case. I did have a version with an earlier patch installed several months ago. Thing is, I've wiped and even formatted the SD card between then and now. Another note is that I've tried installing the unpatched cia, and everything is in japanese, so I'm skeptical of something overwriting the files. There's certainly no trace of anything in the 3ds data management. Is there something I should look for on the sd card?

Edit: I did some more investigating and extracted both the patched and unpatched cias to compare them with the patch files. It seems the patch files for supports are indeed being copied into the cia, but you can see the original files with the japanese filenames are also present. This now leads me to believe that even though the patch has been applied, the game is ignoring those files in favor of the originals. Could that be what's happening?

files.JPG

Edited by Bipolarized

Share this post


Link to post
Share on other sites

I remember getting that same error a couple days ago, but didn't mention it because I didn't use a clean copy of my dump.  Then I found my clean dump, forgot to decrypt it.  Decrypted it, ran just fine.

Do you get the same error with a clean, decrypted dump?

Share this post


Link to post
Share on other sites
5 hours ago, Bipolarized said:

That might be the case. I did have a version with an earlier patch installed several months ago. Thing is, I've wiped and even formatted the SD card between then and now. Another note is that I've tried installing the unpatched cia, and everything is in japanese, so I'm skeptical of something overwriting the files. There's certainly no trace of anything in the 3ds data management. Is there something I should look for on the sd card?

Edit: I did some more investigating and extracted both the patched and unpatched cias to compare them with the patch files. It seems the patch files for supports are indeed being copied into the cia, but you can see the original files with the japanese filenames are also present. This now leads me to believe that even though the patch has been applied, the game is ignoring those files in favor of the originals. Could that be what's happening?

files.JPG

Now that's very odd. The first half of those Live2D files should not have the names they have.

Every patched file is supposed to have the same name as their Japanese copy, but it looks like their names got corrupted. If you take a look inside the "m" folder of the patch you downloaded, do the files look like the top half of the list, or the bottom? If they look like the top half, then I'd recommend re-downloading the patch and using a different program to unzip it. If I had to guess, something that interacted with the files, possibly the program you used to extract them, took issue with the Japanese text and changed all the names as a result.

Edited by ShadySheikah

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...