Jump to content
Sign in to follow this  
DaveLeon

FE2 mage glitch

Recommended Posts

So I was playing Gaiden and some things happened. On chapter 3 I was playing a skirmish with Alm's party. I was going to attack with Cliff, my mage, and instead of the spell selection menu, some glitchy text appeard and Cliff vanished. Afer some waiting he reappeared, but the same thing happened when I tried to attack once again. I decided not to use him and let my turn be over. But as soon as the enemy phase begun... the AI did nothing and the phase wasn't ending... It softlocked. I decided to try a battle with Celica's party and the same happened to Sonia.

It even got worse, at her map sprite got to look like this.

ummm.png

So if anyone knows what's happening here I'd be glad to get an answer.

Thanks for reading.

Share this post


Link to post
Share on other sites

I have played the game quite a bit and have never had this happen to me. My first instinct is to think that you're using a bad rom, translation patch, or code. Change one of those things with the same save file and see if the problem persists. I hope that helps!

Edited by SRC
edited for clarity

Share this post


Link to post
Share on other sites
1 hour ago, DaveLeon said:

So I was playing Gaiden and some things happened. On chapter 3 I was playing a skirmish with Alm's party. I was going to attack with Kliff, my mage, and instead of the spell selection menu, some glitchy text appeard and Kliff vanished. Afer some waiting he reappeared, but the same thing happened when I tried to attack once again. I decided not to use him and let my turn be over. But as soon as the enemy phase begun... the AI did nothing and the phase wasn't ending... It softlocked. I decided to try a battle with Celica's party and the same happened to Sonya.

It even got worse, at her map sprite got to look like this.

ummm.png

So if anyone knows what's happening here I'd be glad to get an answer.

Thanks for reading.

What patch for Fire Emblem Gaiden are you using? I totally think you might have just using je2's old patch that could be bugged with glitches.

Share this post


Link to post
Share on other sites
On 21/1/2017 at 5:17 AM, King Marth 64 said:

What patch for Fire Emblem Gaiden are you using? I totally think you might have just using je2's old patch that could be bugged with glitches.

Well I got a Rom which had that translation patch, but I repatched it with anpther translation and it works just fine. Some numbers and stats are wierd with this new patch, but at least my game isn't broken. Thanks for your concern. ^^

Share this post


Link to post
Share on other sites

The old patch made the game broke if you had Excalibur or Ragnarok. (ANd both Kliff and Sonya have access to the former)

It's a well-known issue.

Share this post


Link to post
Share on other sites
On 2/19/2017 at 8:39 AM, DaveLeon said:

Well I got a Rom which had that translation patch, but I repatched it with anpther translation and it works just fine. Some numbers and stats are wierd with this new patch, but at least my game isn't broken. Thanks for your concern. ^^

What translation did you use to fix it. I'm having the same issue with cliff but none of the patches I'm using is fixing it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...