Jump to content
Sign in to follow this  
TrueNanaya

[Solved] I need some help with animation insertion.

Recommended Posts

I want to insert several animations in all the GBA games but keep running into a problem. I've followed the steps in the animation thread for insertion, but I can't get the game to run afterward or worse. the game crashes when any battle takes place. Here are the steps I took: Open FE Editor Render Edition, go to Class Manager and up the max index by the number of animations I intend to put in, proceed to put in said animations then add the correct information in hex for the classes. If I try to replace existing animations it either freezes up or says something along the lines of using too many editors at once. The animations I'm trying to add/replace are as follows:

FE Binding Blade:

Thief, Thief F, Pegasus Knight, Falcon Knight, Yetizerker,  Lalum w/ Staff, Elphin w/ Magic, Wyvern Lord w/Axes, Soldier Reworked, General

 

FE Blazing Sword:

Thief, Thief F, Pegasus Knight, Falcon Knight, Yetizerker,  Ninian w/ Staff, Nils w/ Staff, Wyvern Lord w/Axes, Soldier Reworked, General, Knight Lord, Hector Lord/ Great Lord

 

FE Sacred Stones:

Thief, Thief F, Pegasus Knight, Falcon Knight, Hawkzerker,  Tethys w/ Staff, Druidmancer, Wyvern Lord w/Axes, Soldier Reworked, General, Great Knight, Female Assassin

I've tried looking through lots of threads to see if a similar problem was reported but I came up empty. Any push in the right direction would be appreciated!

Share this post


Link to post
Share on other sites

So how do I insert the animations then? The animation insertion tutorial says to insert them via FEditor Adv. for all the animations I listed.

Edited by TrueNanaya

Share this post


Link to post
Share on other sites

What Kirb is (unhelpfully) referring to is this. FEditor is known for being, shall we say, difficult; however, the animation assembler won't help for fe6. Did you try adding them all at once, or one at a time? If not the latter, try that. Otherwise, all I can suggest is opening the rom, saving, closing, and then add the animations again, one at a time.

Share this post


Link to post
Share on other sites

I have usually been adding them all at once and then do the hex editing after all the animations have been put in the game. So to make sure, I should add the animations and then save, reload the rom and then add the next and so on? I want to try this first since I know the insertion method before I try something else. Thanks for the advice too by the way!

Share this post


Link to post
Share on other sites

Thanks for the help! Your advice worked and all the animations were inserted successfully! I did the animations one at a time, saving after each insertion as well as closing and reopening FEditor after every insertion. I also checked every animation and they are all working as intended for FE6. When I finish doing the Nightmare edits for it I will try the other method for FE7 and FE8.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...