Jump to content
Eruno

Inserting map sprites

Recommended Posts

okay, so i was having a problem with map sprites, i'm trying to edit Eliwood's standing map sprite, but when i insert it to GBAGE, the colors looks messed up, i edited them in usenti. Anyone know how to fix this? (yes i know i've asked this in chat, but i still couldn't figure it out)

Screenshot_24.png

Edited by Eruno

Share this post


Link to post
Share on other sites
11 hours ago, Eruno said:

umm, sorry i think i posted this  in the wrong place..

Message a mod. They'll help you out. 

Share this post


Link to post
Share on other sites

Moved the thread to Questions.

In GBAGE, when you open up the palette editor and type in the offset for map sprite palettes does it look fine? I don't have the address at hand but you can find it pretty easily with a Google search I'm sure.

Share this post


Link to post
Share on other sites
11 hours ago, Primefusion said:

Moved the thread to Questions.

In GBAGE, when you open up the palette editor and type in the offset for map sprite palettes does it look fine? I don't have the address at hand but you can find it pretty easily with a Google search I'm sure.

first of all, thanks a lot!

It does look fine, and when i insert the original eliwood sprite it looks completely normal, it's just when i insert the edited one (which i didn't mess with the colors at all, just removing the cape from the sprite) the colors got messed up.

 

Share this post


Link to post
Share on other sites

Did you leave "Import Palette" checked when you inserted?

If that's not the case, it would be helpful to know the step-by-step process you took to insert.

Share this post


Link to post
Share on other sites
58 minutes ago, Primefusion said:

Did you leave "Import Palette" checked when you inserted?

If that's not the case, it would be helpful to know the step-by-step process you took to insert.

Okay so i first i imported eliwood's map sprite from the ROM with GBAGE, then i edited them in usenti (only erased bits of the cape, didn't mess with the colors at all), then i requantized it to make sure it was 16 colors, though i don't know why, but when i saved them the blacks on the image turned white (like in the image). Then i inserted them to GBAGE, without importing the palattes and it got messed up like that..

test1.png

Share this post


Link to post
Share on other sites

The requantizing is probably the issue. When you fiddle with map sprites, don't change anything about the color count or palette, and don't import the palette when you insert.

The reason you shouldn't change the color count is that the palette is what is referred to as "Indexed". In this case that means that there's a palette for each team/condition a map sprite can be in (ally, enemy, NPC, arena 4, stoned/already acted, and flashback). Indexed palettes should only ever have their color values changed, but the order and count should never be edited unless you really know what you're doing.

Share this post


Link to post
Share on other sites
12 hours ago, Primefusion said:

The requantizing is probably the issue. When you fiddle with map sprites, don't change anything about the color count or palette, and don't import the palette when you insert.

The reason you shouldn't change the color count is that the palette is what is referred to as "Indexed". In this case that means that there's a palette for each team/condition a map sprite can be in (ally, enemy, NPC, arena 4, stoned/already acted, and flashback). Indexed palettes should only ever have their color values changed, but the order and count should never be edited unless you really know what you're doing.

Well, i tried to not requantize it, and inserted it without importing the palette and it still looks messed up. Then i tried to save it just by using Save (i used Save As before) then when i imported them to GBAGE it looks good, like, it looks like how it should be. But then when i opened my ROM the game froze. Man..

 

Share this post


Link to post
Share on other sites

Try this process:

1. Export a vanilla map sprite (Make sure the palette is correct just so that it doesn't look confusing)

2. Open it in Usenti

3. Paste your map sprite over the top of it and save.

4. Go back to GBAGE, find a compressed image (so that the check box remains checked), and click import.

5. Select your file, type in the offset you'll import to, uncheck import palette, and then click the import button.

6. Click the OK/Done button on the next screen that pops up.

7. Save the ROM

Share this post


Link to post
Share on other sites

Phew.. it worked.. thanks a lot for the detailed process! , and i'm sorry that i made this sound so confusing!  .-.

9 hours ago, Primefusion said:

Try this process:

1. Export a vanilla map sprite (Make sure the palette is correct just so that it doesn't look confusing)

2. Open it in Usenti

3. Paste your map sprite over the top of it and save.

4. Go back to GBAGE, find a compressed image (so that the check box remains checked), and click import.

5. Select your file, type in the offset you'll import to, uncheck import palette, and then click the import button.

6. Click the OK/Done button on the next screen that pops up.

7. Save the ROM

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...