Jump to content
Sign in to follow this  
Flee Fleet!

Desmume lags

Recommended Posts

I posted this topic once before in General, but my poor english speaking skills made things a bit confusing (well, at least I think so).

 

Anyways, DeSmuMe was my main DS emulator and it ran games fine. There was a bit of music lag in some games, but I got used to it.

Then in early 2017, iirc, a problem occurred: Almost all the games except for FE11 and 12 extremely lagged whenever I tried to play them. I restarted my computer to fix the problem and waited a few days, but it didn't get fixed. 

Then I assumed I had too much data in my "C Folder" and deleted unnecessary data. Still made no difference to any of the games. 

They're literally unplayable unless I force myself to get used to it. The only thing I can think of fixing it is changing my laptop's RAM, or get a new graphics card. But I still ask, do any of you have a solution to this problem?

Share this post


Link to post
Share on other sites

I've had it lag a lot before too, but it's usually when I don't have my laptop plugged in :\ And plugging it in fixed things. I've heard that's a general problem with Windows 10 though, so probably not what you're looking for... What kind of computer are you running?

Share this post


Link to post
Share on other sites
11 minutes ago, Solvaij said:

What kind of computer are you running?

I use a Dell laptop that I got in late 2014. My OS is Windows 8. 

 

Edited by Flee Fleet!

Share this post


Link to post
Share on other sites

Have you tried messing with the display settings under Config? That might help... Otherwise, I'm not sure if there's a way to make it run faster :P

Share this post


Link to post
Share on other sites
5 minutes ago, Captain Karnage said:

8.1

8.1 it is, sorry for not saying it before.

 

4 minutes ago, Solvaij said:

Have you tried messing with the display settings under Config? That might help... Otherwise, I'm not sure if there's a way to make it run faster :P

I messed with the display a bit, and only Open Gl along with Filter seem to improve the game speed a little bit, but its still not completely fixed. 

Share this post


Link to post
Share on other sites
34 minutes ago, Solvaij said:

I've had it lag a lot before too, but it's usually when I don't have my laptop plugged in :\ And plugging it in fixed things. I've heard that's a general problem with Windows 10 though

That's an issue with every laptop, since settings for your processor are different depending on whether you have it plugged in or not. I'd suggest keeping it plugged in when you're using desmume, or (if you really don't mind the extra battery drain) right clicking the battery icon on the bottom -> power options OR going into Control Panel -> Hardware & Sound -> Battery Options. Once there, select "High Performance" so the computer knows it can drain extra power for extra performance.

Besides that, if the lag is still an issue, close all other applications before running, and if push comes to shove, PM me your processor, GPU, and RAM availability and I'll see what I can do from there.

Edited by Dizii

Share this post


Link to post
Share on other sites
10 hours ago, Dizii said:

That's an issue with every laptop, since settings for your processor are different depending on whether you have it plugged in or not. I'd suggest keeping it plugged in when you're using desmume, or (if you really don't mind the extra battery drain) right clicking the battery icon on the bottom -> power options OR going into Control Panel -> Hardware & Sound -> Battery Options. Once there, select "High Performance" so the computer knows it can drain extra power for extra performance.

Currently in school, but I'll try that once I get home. Although, iirc, even when plugged in, DeSmuMe lagged, but I'll still check.

 

10 hours ago, Dizii said:

Besides that, if the lag is still an issue, close all other applications before running

I did that before, it didn't work.

 

10 hours ago, Dizii said:

if push comes to shove, PM me your processor, GPU, and RAM availability and I'll see what I can do from there.

Sure, and thanks.

 

Also, I forgot to mention this, but:

Putting my laptop to sleep while DeSmuMe is on, and then turning my laptop on again, makes the application run faster than normal, although its only for like 2 minutes at best.

Share this post


Link to post
Share on other sites
On 1/28/2018 at 2:44 PM, Captain Karnage said:

8, or 8.1 that may be the problem

This isn't related to emulation, but are you THE Karnage? And is it true that if Mangs feeds you experience, you will level up?

Share this post


Link to post
Share on other sites
10 hours ago, halos said:

This isn't related to emulation, but are you THE Karnage? And is it true that if Mangs feeds you experience, you will level up?

yes

___________________________

@Flee Fleet! how bad is it, I've experienced some lag on it before, and I've seen a few LP's, it always had some minor lag.

Share this post


Link to post
Share on other sites
On 1/29/2018 at 12:54 AM, Dizii said:

That's an issue with every laptop, since settings for your processor are different depending on whether you have it plugged in or not. I'd suggest keeping it plugged in when you're using desmume, or (if you really don't mind the extra battery drain) right clicking the battery icon on the bottom -> power options OR going into Control Panel -> Hardware & Sound -> Battery Options. Once there, select "High Performance" so the computer knows it can drain extra power for extra performance.

Okay, so I changed battery settings to "High Performance" and it definitely worked. DeSmuMe is working way faster and better immediately. Setting the battery option to "Balanced" also greatly increases it's speed.

I guess me changing the battery settings to "power saver" was what resulted for the games to lag so much. Thank you for this info, I should've realized it was so simple, haha. 

 

10 minutes ago, Captain Karnage said:

how bad is it, I've experienced some lag on it before, and I've seen a few LP's, it always had some minor lag.

Due to keeping the battery settings on "Power saver", the lag greatly increased to the point that music became too slow and characters too like 5-10 seconds to move....okay, maybe I'm not giving the most accurate description, but its the best way I can say it, sorry.

 

The minor lag was always an issue though, although mainly with the music. I can tolerate it though, at least, and it can be fixed by spamming the pause button.

Edited by Flee Fleet!

Share this post


Link to post
Share on other sites
1 hour ago, Flee Fleet! said:

Okay, so I changed battery settings to "High Performance" and it definitely worked. DeSmuMe is working way faster and better immediately.

Glad my advice helped! :):

Just remember to turn it back to power saver while using it at school / anywhere without charger access, since it will drain quite a bit faster while set on high-performance.

Share this post


Link to post
Share on other sites
18 hours ago, halos said:

This isn't related to emulation, but are you THE Karnage? And is it true that if Mangs feeds you experience, you will level up?

Hello, I presume you followed me for being the Rezzy?

Share this post


Link to post
Share on other sites
17 hours ago, Dizii said:

Glad my advice helped! :):

Just remember to turn it back to power saver while using it at school / anywhere without charger access, since it will drain quite a bit faster while set on high-performance.

I'll keep that in mind, although I don't tend to use it anywhere outside my room, haha.

Share this post


Link to post
Share on other sites
20 hours ago, Rezzy said:

Hello, I presume you followed me for being the Rezzy?

yeh m8

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...