Jump to content
mental_offence

How to play FEH on PC (Windows only)

Recommended Posts

Fire Emblem Heroes runs on these emulators: BlueStacks, NoxPlayer, MEmu and LDPlayer.

BlueStacks and NoxPlayer require no extra steps, but they are the most demanding emulators. Not recommended for low-end PC users.
LDPlayer requires no extra steps either, but it works better on low-spec machines.
MEmu takes more time to set it up, but it has the best performance of all emulators, especially on low-spec machines.

Prerequisites for all emulators:

Notes:

  • Important! You have to sign in with any Google account if you want to summon heroes, otherwise you'll get 803-3021 error.
  • Important! Only arm (armeabi-v7a) version of FEH works on most emulators. You can install arm64 (arm64-v8a) apk only on MEmu Android 7 64-bit image (microG_716_76.ova).
  • All emulators (but BlueStacks) are prerooted so you can reroll by removing deviceAccount:.xml file from data/data/com.nintendo.zaba/shared_prefs using any file manager with root access.
  • Preinstalled browsers on some emulators don't work, in that case download any other internet browser to sign in with Nintendo account.
  • You can run FEH in tablet mode. Go to settings of any emulator and set custom resolution to anything with 4:3 or 5:4 aspect ratio (such as 1024x768 or 1280x1024).

 

 

BlueStacks

Just download BlueStacks and install it. Download FEH from Play Store or get apk elsewhere and install it.

 

 

NoxPlayer

Just download NoxPlayer and install it. Use prebundled Android 5.1 instance or create a new Android 7.1 one in Multi-Drive. Download FEH from Play Store or get apk elsewhere and install it.

 

 

LDPlayer

Just download LDPlayer (Android 7.1 version is preferable) and install it. Download FEH from Play Store or get apk elsewhere and install it.

 

 

MEmu

  1. Download MEmu 7.1.6 (don't download latest version from official site!) and install it. Don't launch MEmu when installation finishes, just close the installation window.
  2. Download microG_716_41.ova (Android 4.4), microG_716_51.ova (Android 5.1), microG_716_71.ova (Android 7.1, recommended) or microG_716_76.ova* (Android 7.1 64-bit).
  3. Open Multi-MEmu, press "Import" - "Import From File" and choose downloaded ova file.
  4. Start the ova you imported just now. First launch may take a while (1-3 minutes).
    4.1. If you're using microG_716_76.ova (Android 7.1 64-bit), after your instance is launched and you're at home menu - install FEH, log in and download all data, when you'll get to home screen -  close FEH and start it again, wait until you get to home screen again, close the game and then restart your instance of MEmu. This must be done only once after initial installation of FEH.

Download FEH from Play Store or get apk elsewhere and install it.
MEmu launcher is replaced with default android launcher and File Manager is replaced with MiXplorer, simple and fast file manager with root access.
*Android 7.1 64-bit instance is somewhat unstable, sometimes FEH won't start or will crash randomly.

 

This thread is no longer being supported by me, however I may update it from time to time.

Spoiler

Thanks to @mampfoid, @darketernity, @zen, @Warsteiner and this guy 1.jpg.486d38163d7a87fa95bfa81b1d25b78e.jpg for testing new version of MEmu.

Thanks to @lifeisfkup for the discovery of FEH being playable on LDPlayer.

 

Edited by mental_offence

Share this post


Link to post
Share on other sites
2 minutes ago, ZeManaphy said:

Are you able  to link accounts on an emulator?

Yes. At least back when I used one, half a year ago. Indeed it was essential since you regularly get locked out and have to reset and relink. You can't change your display name though, so I was Kiran for months on end.

Share this post


Link to post
Share on other sites

Good Idea, perhaps I'll try this on my PC.

Useful information for the OP would be if there are any preconditions to the Windows Version or the PC in general. 

Share this post


Link to post
Share on other sites
45 minutes ago, kratosangel said:

I still have the 2.9 something version of Memu and any time I try to download and install the 2.2 apk, it says "failure to install the APK".

Am I forced to move on to 3.3.0.2 version ?

Not forced, but you probably should do that anyway.

 

43 minutes ago, mampfoid said:

Good Idea, perhaps I'll try this on my PC.

Useful information for the OP would be if there are any preconditions to the Windows Version or the PC in general. 

MEmu works only on Windows - so there's that.

Share this post


Link to post
Share on other sites
1 hour ago, mental_offence said:

MEmu works only on Windows - so there's that.

No matter if Windows XP, 7, 8 or 10? 

Should my CPU support certain features (virtualization, X-core) to run FEH smoothly? 

Share this post


Link to post
Share on other sites
31 minutes ago, mampfoid said:

No matter if Windows XP, 7, 8 or 10? 

Should my CPU support certain features (virtualization, X-core) to run FEH smoothly? 

Any x64 version of Windows should work.

Hardware virtualization MUST be enabled in bios, MEmu won't load otherwise. MEmu by itself doesn't require much computing power, as it works perfectly on my laptop with intel 2020m cpu.

Share this post


Link to post
Share on other sites
37 minutes ago, mental_offence said:

Any x64 version of Windows should work.

Hardware virtualization MUST be enabled in bios, MEmu won't load otherwise. MEmu by itself doesn't require much computing power, as it works perfectly on my laptop with intel 2020m cpu.

Ok, thank you.

I don't know how many of the modern CPUs support hardware virtualization, but I guess mine should. 

Share this post


Link to post
Share on other sites
8 minutes ago, EzraFitz said:

I wanted to instal the 2.2 but every time i import the files the program said "Failled to import" can you help my pls

Are you sure you have Lollipop for MEmu installed? Also newer versions of MEmu won't work with those ovas, only versions up to 3.3.0.2.

Share this post


Link to post
Share on other sites
3 minutes ago, EzraFitz said:

yes i actually download and install the file named Memu-Lolipop-rc5

Hmmm... Not sure why is this happening. Probably some hardware/software incompatibilities.

You can try installing MEmu 2.9.6.1 instead of 3.3.0.2, but I'm not sure if this will help.

Share this post


Link to post
Share on other sites

I'm unable to access Shop since 2.1.0. It just stays in loading forever. Can you advise?

Edit: Ok, I found a way.

I enabled apps related to Google Services in the Apps section in Settings. Updated them all (including the google services one Fire Emblem kept nagging me about) and I could access the shop.

Maybe this causes 803-3001 but in that case I can have two separate memu instances in multi-memu. One for playing without interruptions and the other for accessing shop. During my short gameplay test the error 803-3001 did not occur.

Edited by real_Aphyxia
Solution

Share this post


Link to post
Share on other sites
4 hours ago, real_Aphyxia said:

I'm unable to access Shop since 2.1.0. It just stays in loading forever. Can you advise?

Edit: Ok, I found a way.

I enabled apps related to Google Services in the Apps section in Settings. Updated them all (including the google services one Fire Emblem kept nagging me about) and I could access the shop.

Maybe this causes 803-3001 but in that case I can have two separate memu instances in multi-memu. One for playing without interruptions and the other for accessing shop. During my short gameplay test the error 803-3001 did not occur.

Have you tried turning off and on again? Were you able to log back in with the one you had access to the shop?

Edited by ogolge

Share this post


Link to post
Share on other sites
On 2/9/2018 at 5:15 PM, ogolge said:

Have you tried turning off and on again? Were you able to log back in with the one you had access to the shop?

Yes. Turning memu on and off, no problems in game.

A day after though i get the error. It seems it presents itself after some time has passed. Maybe there is a workaround for this but for now I'll just do this instance if I need access to the store. I don't need it that often.

Edited by real_Aphyxia

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...