Jump to content
Theri

Something wrong with script

Recommended Posts

I've already combed through this script multiple times, and I can't seem to find the issue. Event Assembler tells me everything is fine when I run it through, but whenever I open the ROM, the entire game is messed up. The script is written in the spoiler. If anyone can take a look through it and perhaps tell me if there's something wrong, I'd really appreciate that. The title and opening scene of the game is fine, but when I go to the menu, it no longer works (screenshot below).

Spoiler

#include EAstdlib.event

EventPointerTable(0x7,ThisChapter)

ORG 0x8B0890
ALIGN 4
ThisChapter:

POIN TurnBasedEvents
POIN CharacterBasedEvents
POIN LocationBasedEvents
POIN MiscBasedEvents
POIN Dunno Dunno Dunno
POIN Tutorial
POIN Ballista1 Ballista2
POIN Units1 Units1
POIN $0 $0 $0 $0 $0 $0
POIN BeginningScene EndingScene

TurnBasedEvents:
TURN

CharacterBasedEvents:
CHAR 0x12 JayRecruitment Eirika Gerik 0x00
END_MAIN

JayRecruitment:
MUSS 0x30
Text(0x099A)
CUSA 0x14
MURE 5
ENDA

LocationBasedEvents:
END_MAIN

MiscBasedEvents:
DefeatBoss(EndingScene)
AFEV

Dunno:
//DO NOT TOUCH
BYTE $00

Tutorial:
//DO NOT TOUCH
BYTE $00

Ballista1:
BLST

Ballista2:
BLST
ALIGN 4

Units1:
UNIT Eirika 0x02 0x0 Level(1,Ally,0) [17,8] 0x00 0x00 0x1 EirikaREDA [0x09,0x6C] NoAI
UNIT Ephraim 0x01 0x0 Level(1,Ally,0) [17,8] 0x00 0x00 0x1 EphraimREDA [0x78,0x6C] NoAI
UNIT Lute 0x26 0x0 Level(1,Ally,0) [9,12] 0x00 0x00 0x0 LuteREDA [0x38,0x6C] NoAI
UNIT

EirikaREDA:
REDA [7,10] 0x0 0x0 0x0 0x0

EphraimREDA:
REDA [9,10] 0x0 0x0 0x0 0x0

LuteREDA:
REDA [8,10] 0x0 0x0 0x0 0x0

Units2:
UNIT 0x86 0x13 0x0 Level(2,Enemy,0) [6,7] 0x2 0x0 0x0 0x0 [0x01] AttackInRangeAI
UNIT 0x81 0x19 0x0 Level(2,Enemy,0) [7,6] 0x2 0x0 0x0 0x0 [0x2D] AttackInRangeAI
UNIT 0x85 0x05 0x0 Level(2,Enemy,0) [8,7] 0x2 0x0 0x0 0x0 [0x01] AttackInRangeAI
UNIT 0x84 0x09 0x0 Level(1,Enemy,0) [3,3] 0x00 0x0 0x0 0x0 [0x14] AttackInRangeAI
UNIT 0x85 0x05 0x0 Level(2,Enemy,0) [6,4] 0x00 0x0 0x0 0x0 [0x14] AttackInRangeAI
UNIT 0x14 0x0F 0x0 Level(2,Enemy,0) [4,2] 0x00 0x0 0x0 0x0 [0x1] GuardTileAI
UNIT 0x46 0x4E 0x0 Level(5,Enemy,0) [10,2] 0x00 0x0 0x0 0x0 [0x14,0x1C] GuardTileAI
UNIT

BeginningScene:
CAM1[7,7]
FADU 30
LOAD2 0x1 Units1
LOAD1 0x2 Units2
ENUN
Text(0x0908)
CAM1 Gerik
Text(0x090E)
FADU 30
ENDA

EndingScene:
STAL 0x01
Text(0x03,0x0954)
ENUN
MUSC 0x29
Text(0x20,0x0962)
MNCH 0x02
ENDA


MESSAGE Events end at offset currentOffset

 

Screen Shot 2018-10-04 at 10.55.48 PM.png

Share this post


Link to post
Share on other sites

The most likely answer would be that you accidentally overwrote something. I'm not sure if you've successfully inserted events before (in which case you probably already know this and you can ignore everything I'm about to say lol) but if you're new to this, you have to be careful with the offset you insert the events at. Maybe you made a typo when you put in the offset or something, but there's data already at 0x8B0890. Make sure there's free space wherever you insert custom things (A hex editor is your friend) or funky phenomena can happen.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...