Jump to content

Recommended Posts

Greetings, fellow Fire Emblem enthusiasts!

First time posting as someone who has been enjoying messing around with FEBuilder to create some interesting changes for myself and a friend to enjoy casually.
I am mainly using it as a way to learn, but have run into a few issues which I have not been able to find a solution for. I don't wish for anyone to work themselves to the bone to fix them, but if anyone happens to know what the cause and solution is I'd very much appreciate the help.

Right. Onto the issues I've been unable to resolve. At the end of this post I will list some of the bigger changes I do recall making.
I do not know if these issues are related.

Issue number 1:
I've found myself getting some strange text-bugs where the game vomits the letter s on a screen repeatedly, and ends it with the word "broke!", which does not seem to be taken from text adress 3, as changing the text "broke!" in that adress does not change the text in the bug. This bug occurs when I examine an item without a 'use' description, or level up my weapon skill. From what little reference I've seen to these types of issues online, it seems like there may have been a change to some ID that shouldn't have been changed waaaaay back - so I'm afraid I can't remember what I've changed. I have not been able to find any instructions on what to do about it.

I wasn't very careful with what I was doing at the start, since I didn't think I'd be putting in the many hours I have into this.
Here's what the issue looks like.
Item Use description
Weapon Rank-up text

Issue number 2
My second, more gamebreaking issue is one that does not just affect graphics.
It stems from the SkillSystem patch, as I've been trying to assign characters with interesting and useful skills.

Specifically, the issue lies in all skills that affect combat range. Point Blank for letting archers attack adjacent enemies, as well as +1 range on both bows and spells are a problem.
Whenever I use the added range to attack an enemy capable of attacking back, my character with the skill has their attack skipped and the game proceeds directly to the enemy attack. I deal no damage, and my character doesn't move. It just acts as if the enemy attacked me and I was unable to counter.

What's even worse is when I attack an enemy that can't attack back. At that point, the combat-screen opens and both models just stand there until I close the game.

What's weird to me is that changing the range of the weapons themselves lets me attack at at 3x range or with bows at 1x range, so it's not an animation issue. The only issue is when the skills are what should allow me to attack, rather than the weapons default range.

What I can recall doing:
One obvious big change is the skill system patch.

Another is the fact that I used the YUNE randomizer before I started modifying the game, swapping around characters and classes, as well as weapon stats.

At the very start, I recall copying and pasting things like palettes, before finding that doing so causes the palettes to use the same ID and changing one therefore changes both. I've been much more careful with what I copy where since, but it is possible something like that is behind the issues I'm having. 

Finally, I'll provide a list of my installed patches. 

Spoiler

16_tracks_12_sounds
Fix CG Fade Glitch
Map Danger Zone (Select: Toggle)
Remove Enemy Controm Glitch
Display Escape Menu
ExModularSave
ExModularSave with Supply of 200
FE8-Battle Stats with Anims Off
Attack and capture enemies with reduced speed like FE5(Tequila Version)
Rogue Robbery
01command_hack
48command_hack
Anti-Huffman
fix_lz77decompress
HPBars_with_warnings
HPBars_with_warnings Cache
HPBars_simple
Improved Sound Mixer
Magic Sword Rework (Installer)
Add Event Condition: Tile Change
Skip World Map Fix (For World Map Users)
NarrowFont
Change Max HP limit to use set in class editor
Skill SkillSystems 20201128
Stairs 20191031
UnitActionRework

Thanks in advance.
- Noel Woodsoul

Edited by Noel_Woodsoul

Share this post


Link to post
Share on other sites

Hmmm, I would say to try it without using the randomizer and see what happens first. 

I dont know if that intended to be compatible with the skills patch or not, so I would test it to be sure.

Share this post


Link to post
Share on other sites

Having gone through some of my old backup files, I've found that my very first save with both skill systems and Yune works in both regards.
My second version works in regards to the range skill, but has the broken text.

Is there a way to compare the two roms to see what I changed between them without risking accidentally creating over 2 million .bin files like I accidentally did last time I tried this?

Edit: While I haven't managed to perfectly recreate the issue, I've managed to break it in a similar way by taking this rom and saving data in text adress 0000 and then removing it... So it seems likely that I've saved something where it shouldn't be saved. Is there a fix to this, like manually going in and entering the correct hex values or something? I'm starting to suspect the normal user interface won't be enough, and I really don't want to have to start over from scratch given the amount of hours I've put into this already.

Edit 2: I've found that uninstalling and reinstalling skills fixes the range issue, so I guess I ought to begin the daunting task of documenting all the skills I've assigned in the game so I can reinstall them. Still no progress on the text issue though.

Edited by Noel_Woodsoul

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...