Jump to content

FEditor Adv Problem


Recommended Posts


So I have been working on a hack project for a while in my spare time now. Every time I faced a problem I managed to find the answer online (Thank this website) or found it myself.

Anyway, I'm about a quarter into the hack I'm making and I was gonna import another animation from Fire Emblem 8 into Fire Emblem 7. But then this weird s*** happened.

When I click on Class Animation Manager, nothing happens. It worked fine before. But now suddenly it doesn't. I was thinking it might have to do with something I have overwritten, but I haven't touched anywhere near the offset where FEditor patches.

Here's a gif:


As you see, the Portrait editor works fine (So does the Text and Class Animation Creator), but the Class Animation Manager (and Spell Animation Inserter, but I don't need it now) don't work.

It works fine on a clean rom, but I really don't want to start over again. It would take me a long time to import all songs, data, chars, etc back into the rom.

Anyone have any ideas?

Edited by Dethraxx
Link to comment
Share on other sites

every time you open FEditor, save the ROM without doing anything before you start your work. Trust me, this is a very necessary.

if this doesn't work, you may have to fight with the metadata in the ROM's footer, which is... nontrivial.

Link to comment
Share on other sites

I tried what you told me, but it still didn't work. :(

Would you have any other ideas? Cause I have no clue on how to mess with the ROM's Footer.


I tried saving 2 times in a row and for some reason it worked now.

Thanks! Haha!

Edited by Dethraxx
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...