Jump to content

Buildfile Not Working?[SOLVED]


Recommended Posts

So I recently decided to switch how I'm creating my romhack to a Buildfile, and I'm at the point where I have tables done and installers for that, and maps too, but I'm not certain how to do an installer for events? I tried just having an event file that included the chapter events, but I saw no change in any property when I applied the buildfile. EA didn't reject the file either.

Obviously when it comes to a Buildfile there's a lot of code to share, but I don't wanna overwhelm people so I'll just start with the base buildfile and then post on request.


#include "Hack Definitions.txt"
#include "EAstdlib.event"

#define FreeSpace 0xD00000
ORG FreeSpace
#define INLINE
MESSAGE "Used free space starts at CURRENTOFFSET"

#include "Tables/Table Definitions.txt"
#include "Tables/Table Installer.event"

#include "Install Character Text Data.event"
#include "Install Class Text Data.event"

//Chapter Events
#define InlineEvents
#include "Chapter Events/Chapter Events Installer.txt"

#include "Maps/Master Map Installer.event"

#undef InlineEvents


Link to comment
Share on other sites

  • thewispsoftime changed the title to Buildfile Not Working?[SOLVED]

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...