Jump to content

Search the Community

Showing results for tags 'feditor adv'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Important Links
    • Serenes Forest Code of Conduct
    • Mistakes or Errors on the Site
  • Important Forums
    • Announcements
    • Member Feedback
    • Site Content
  • General Forums
    • Introductions
    • General
    • Far from the Forest...
    • Creative
    • Fan Projects
    • General Gaming
  • Fire Emblem Forums
    • General Fire Emblem
    • NES and SNES Era
    • GameBoy Advance Era
    • GameCube and Wii Era
    • Nintendo DS Era
    • Nintendo 3DS Era
    • Fire Emblem: Three Houses
    • Fire Emblem Heroes
    • Fire Emblem Warriors
    • Tokyo Mirage Sessions #FE
  • Miscellaneous
    • Forum Graveyard

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Interests


Location

Found 7 results

  1. I've recently gotten into the Fire Emblem Hacking community as of late. While I still consider myself a complete and utter newb when it comes to ROM Hacking, I have everything regarding basic usage of Nightmare down. The real pain in the keyster comes with using Feditor Adv, more specifically, the text editor. I've looked up tutorials, FAQs, and even swam through Blazer's old forums but I can not for the life of me get down editing weapon names and their descriptions. The game I'm trying to hack is Sacred Stones. Yes, I am using a clean, USA version of the game. The game opens up just fine when i start the program, I do the save and exit and reopen trick to make sure nothing glitches up, thats all fine and dandy. But whenever i finish making my text adjustments, they never carry over into the game itself. I have tried each and every single way of doing this dang thing on multiple copies of the same unaltered ROM. Clicking apply and save for every change like nightmare, clicking apply every time and saving at the very end, making all my changes with nightmare first then close it and then changing the names on that same ROM but still no dice. I'll load the Rom a few seconds later and none of the name changes stick (all the statistical ones do on the other hand.). At this point I feel like I'm missing something obvious and any major assistance or advice would be greatly appreciated. The version of Feditor I'm using comes from romhacking.net . I haven't tried anything else with Feditor, just the text editor. Can anyone please help me realize my dream of turning Lute into the second coming of Tiny Hands Reinhardt?
  2. OK, so I have run into a bit of a dilemma when trying to edit the text of Fire Emblem 7. See, I'm trying to translate the game into Irish, a language that uses the diacritical marks á, ó, ú, í and é. So, I thought, since the game has a Spanish localization, and the Spanish language has all of those diacritical marks, I can just edit that right? Well, it turns out FEditor Adv will only except ROMs of the American version of the game. So, I tried editing an American ROM, but the character "á" showed up as "?" in game. I've heard that if you can decompress the Huffman compression on the text in the ROM, you can edit the text manually with a Hex editor, like here, but I have no idea how I'd go about doing it with the Spanish ROM. So, is it possible to either edit the text of a European version of the game, or add new text characters into the American version, and if so, which would be easier? Thanks in advance for any replies.
  3. The download worked just fine yesterday, but now dropbox is giving me the error 404 message. There are no other working download links that I know of. If someone could explain what's going on that'd be nice...
  4. So I'm working on my hack and I manage to insert axe cavalier animations, they work fine. they are in the game and working fine upon testing. After that I consider using different axe cavalier animations so I opt to test them and see how they look ingame, I then run into a problem with FEditor giving me this error message "Caused by: java.lang.RuntimeException: This ROM appears to have been hacked outside FEditor (wrong checksum) and the pointer array has been relocated... FEditor can't handle this properly since the array size is unknown." I then start again from a clean rom, doing each step then testing FEditor and it seems what messes this up is when I use nightmare to repoint the animation of the female cavalier to 0x8FFF800 which is at the start of the custom animation pointers for the nightmare module, I don't understand what's going wrong with FEditor as the animation is working fine in the game. did I forget to repoint something in FEditor or for FEditor so it wouldn't run into this problem?
  5. Hey. So I have been working on a hack project for a while in my spare time now. Every time I faced a problem I managed to find the answer online (Thank this website) or found it myself. Anyway, I'm about a quarter into the hack I'm making and I was gonna import another animation from Fire Emblem 8 into Fire Emblem 7. But then this weird s*** happened. When I click on Class Animation Manager, nothing happens. It worked fine before. But now suddenly it doesn't. I was thinking it might have to do with something I have overwritten, but I haven't touched anywhere near the offset where FEditor patches. Here's a gif: https://gyazo.com/ad3cdc3e48f091397ad9a43c377baa2f As you see, the Portrait editor works fine (So does the Text and Class Animation Creator), but the Class Animation Manager (and Spell Animation Inserter, but I don't need it now) don't work. It works fine on a clean rom, but I really don't want to start over again. It would take me a long time to import all songs, data, chars, etc back into the rom. Anyone have any ideas?
  6. I need help with custom animations. Can anyone make Mage Knight with Sword please? I would appreciate it if you have pre-made sprites and a pre-made script.
  7. I would like to insert a custom sound as a 0x85 command for use in custom battle animations. Like instead of C49 to play a sage casting sound, I want to use C53-CFF to play whatever sound I insert. I think I need to find the pointer table for battle animation commands, and point the empty commands to my sounds, but I have no idea how to find pointer tables. I was able to find the pointer table for spell animations in this thread: http://serenesforest.net/forums/index.php?showtopic=27569 I was also able to find this bit of code inside FEditor\src\Model\AnimationBuilder.java: // For appending 0x85 commands onto the frame data to play any soundpublic void addSoundCommand(short musicID) {if (mode == MAX_MODE_COUNT)return;if (mode == 0 || mode == 2) {// NOP command to avoid anticipated issuesBGframeData.add(AnimationCommand.normal((byte)0, (byte)0));}add_helper(AnimationCommand.sound(musicID));if (hasLoop)wordCount++;}// addCommand method; tested and working!so it seems like this is definitely possible. I just have no idea how to actually do it.EDIT: I managed to (sort of) get it working. I used Sappy to find some of the sound effects. For my example I used Song 231 in FE8, which is the Brigand's war cry. I used Import Sample to put my WAV file at 0x0EA0000 and put in an instrument map at 0x0E80000: 00C00000 0000EA80 (pointer to WAV file) FF00FF00. Then I made a MIDI with one note and inserted it in place of Song 231, using the instrument map at 0x0E80000. Now when I use C33 in a battle animation it plays my WAV file instead of the Brigand war cry. HOWEVER there is still a problem, because around 50% of the time the sound fails to play. Also even if I get that working, this will only work for a very limited number of sounds. Does anyone have any advice? DOUBLE EDIT: Discovered the SXXXX command which lets you play whatever sound you like, so I'm filling in the blank sounds on the music table. This means I can have a huge number of possible sound effects. You do have to go into the song table and change the 00 00 00 00 of blank songs to 06 00 06 00, otherwise it cuts the music. But the sound still fails to play around half the time, seemingly without reason. FINAL EDIT: Got my solution, in case anyone else has the same issue. http://feuniverse.us/t/playing-custom-sounds-in-battle-animations/1034/3
×
×
  • Create New...