Jump to content
bookofholsety

FE4 Translation Patch (Open Beta v7)

Recommended Posts

13 minutes ago, Awyn Würde said:

I'm having trouble with the rom on a SNES emulator for PSP

Does the emulator support 8 MB ROMs? Because many don’t.

Share this post


Link to post
Share on other sites

Is this project still going on? 

I'm just trying to figure out if I should wait or go with the beta patch. I don't mind waiting, but if a new version isn't planned then I'll go with the beta.

Finally trying to get into the jugdral games now that fe5 has an active translation that has a functional menu :D

Share this post


Link to post
Share on other sites
38 minutes ago, VongolaBossX said:

On chapter 8 how come it doesn't show muhammad's droppable brave lance?

Do you have the brave lance already on someone?

Because thst's the only brave lance in the game for you.

Share this post


Link to post
Share on other sites

I tried to play this on SNES9x (newest version) as I could not play it on my usual ZSNES, I applied the header patch as I followed the instructions on readme and right after the opening story the screen froze and didn't even let me start the game ;/ here's a screenshoot!

Fire Emblem-Genealogy of the Holy War-(Seisen no Keifu)000.png

UPDATE: My bad! Tried again with a 'non-patch' Japanese rom of the FE4 game and it worked! ;P Well, my mistake may help others in the same situation, it doesn't work if you patch a previously translated/patched version, it doesn't matter if it's the first English patch that got released a million years ago before this project, so make sure to use a Japanese rom to use the patch!

P.S. Any news on the final version of the beta? O_o It looks like it's pretty advanced! Hopefully it's complete soon, I'd love to play the whole experience! <3
And a full translated and improved version of Thracia 776 some time in the future too! :) 
Cross my fingers!!! xx

Edited by BlackMagdalene

Share this post


Link to post
Share on other sites

Hi, iv'e spent the past hour and a half doing all of the correct steps for patching the rom with the new translation but in bsnes it doesn't even acknowledge the game as being in the folder to load from if anyone could help me that'd be great.

Share this post


Link to post
Share on other sites
18 hours ago, Arexu said:

Hi, iv'e spent the past hour and a half doing all of the correct steps for patching the rom with the new translation but in bsnes it doesn't even acknowledge the game as being in the folder to load from if anyone could help me that'd be great.

Does Bsnes suport 8mb roms?

Share this post


Link to post
Share on other sites
1 hour ago, sirmola said:

Does Bsnes suport 8mb roms?

I don't know myself but i got Snes9x and it's working perfectly now.

Share this post


Link to post
Share on other sites
On 9/12/2017 at 1:08 PM, Vaximillian said:

Does the emulator support 8 MB ROMs? Because many don’t.

Could you elaborate? I too have had trouble trying to play the game with this patch on every available PSP SNES emulator. Would you happen to know of one that does or is playing a rom of this size on PSP just simply not possible?

 

Share this post


Link to post
Share on other sites

I have run into a strange bug while playing this game with this translation. If someone is able to Canto after killing Julius, after the events that occur if both Manfroy and Julia are still alive and enemies, the chapter's sound track becomes a distorted version of the the chapters theme (although the no enemy theme should be playing), and some inconsistent graphical bugs appear too. After a little messing around here are some things I have noticed about this bug:

I am fairly certain it involves Canto, I am able to trigger it with both a Mounted Seliph and Ares, while a dismounted Seliph and Faval will not

The distortion in music seems to specifically effect the chapter music, using a Staff, or having someone enter a castle, or participate in the arena seems to have the normal sounds play but even when it returns to the map, the music seems to still be distorted.

Ending the turn seems to fix this as long as the sound errors have not hit the point where the sound track cuts out or becomes static.

If the sound cuts out or becomes static, anything that changes the music that I have tried (using a staff, entering a castle or ending the turn and letting the NPC turn start) seems to soft-lock the game.

Edit: I have found another very strange effect of this bug, it seems to have the lingering  effect of setting every character's loss record to 132

 

I have included a .srm file for the save with the following instruction for reproducing the bug:

Start from the turn46 save for the epilogue chapter

Have Sleiph besiege Julius with the Tyrfing then Canto over to the other side of Lene

Have Shanan besiege Julius with the Balmung

Have Lene Dance in place.

Move Shanan away from the Castle entrance

Have Ares besiege Julius with the Mystletainn and Canto away*

From here Seliph can kill Julius if besieged with Tyrfing (Note that if Faval attacks Julius with the Yewfelle or if Seliph dismounts before besieging they will still get the kill but the bug will not be triggered)

After the clearing the dialogue boxes the bug is evident

*For Ares to kill Julius have Seliph besiege with Tyrfing, Canto away and then have Ares Besiege with the Mystletainn

 

Fire Emblem - Geneology of the Holy War.srm

Edited by Eltosian Kadath
fixed grammar, extra discoveries

Share this post


Link to post
Share on other sites
On 10/3/2017 at 1:32 PM, Lucis said:

Could you elaborate? I too have had trouble trying to play the game with this patch on every available PSP SNES emulator. Would you happen to know of one that does or is playing a rom of this size on PSP just simply not possible?

 

The SNES emulator on PSP does not support 8MB ROMs, AFAIK.

21 hours ago, Eltosian Kadath said:

I have run into a strange bug while playing this game with this translation. If someone is able to Canto after killing Julius, after the events that occur if both Manfroy and Julia are still alive and enemies, the chapter's sound track becomes a distorted version of the the chapters theme (although the no enemy theme should be playing), and some inconsistent graphical bugs appear too. After a little messing around here are some things I have noticed about this bug:

I am fairly certain it involves Canto, I am able to trigger it with both a Mounted Seliph and Ares, while a dismounted Seliph and Faval will not

The distortion in music seems to specifically effect the chapter music, using a Staff, or having someone enter a castle, or participate in the arena seems to have the normal sounds play but even when it returns to the map, the music seems to still be distorted.

Ending the turn seems to fix this as long as the sound errors have not hit the point where the sound track cuts out or becomes static.

If the sound cuts out or becomes static, anything that changes the music that I have tried (using a staff, entering a castle or ending the turn and letting the NPC turn start) seems to soft-lock the game.

Edit: I have found another very strange effect of this bug, it seems to have the lingering  effect of setting every character's loss record to 132

 

I have included a .srm file for the save with the following instruction for reproducing the bug:

Start from the turn46 save for the epilogue chapter

Have Sleiph besiege Julius with the Tyrfing then Canto over to the other side of Lene

Have Shanan besiege Julius with the Balmung

Have Lene Dance in place.

Move Shanan away from the Castle entrance

Have Ares besiege Julius with the Mystletainn and Canto away*

From here Seliph can kill Julius if besieged with Tyrfing (Note that if Faval attacks Julius with the Yewfelle or if Seliph dismounts before besieging they will still get the kill but the bug will not be triggered)

After the clearing the dialogue boxes the bug is evident

*For Ares to kill Julius have Seliph besiege with Tyrfing, Canto away and then have Ares Besiege with the Mystletainn

 

Fire Emblem - Geneology of the Holy War.srm

This bug happens on an unpatched game, IIRC. Something to do with IRQ timings and the animation of the Loptyr tome attack, from what I remember DDS saying.

Share this post


Link to post
Share on other sites

Hi.

I edit a fanzine called HyperPlay RPG. We'd like to run a story on this excellent project but can't get the Beta (v7) to work. We're running the latest SNES9X GX on the Wii Homebrew Channel. We've tried both combinations of headered/unheadered IPS patches. It appears our ROM is the slightly larger headered version, pure Japanese, but even that doesn't work when properly patched. All patches and the ROM were properly unzipped. The vanilla ROM works fine - with Japanese text. Once patched, though, we get "Invalid File Size!" from SNES9X GX when trying to load. This is probably because the file size is 8,193 Kb, twice that of other patched ROMs which work fine.

Is there a workaround please? It would be a great shame not to cover this project in the fanzine (we have over 1,000 readers worldwide).

Please let me know by replying here, and/or getting in touch by email [email protected] or on twitter @hyperplayrpg

Many thanks!

Kincl - Editor, HyperPlay RPG (hyperplayrpg.com)

EDITED: SOLVED! SEE MY OTHER POST BELOW

Edited by Kincl
Solved.

Share this post


Link to post
Share on other sites
On 10/3/2017 at 8:16 AM, Arexu said:

I don't know myself but i got Snes9x and it's working perfectly now.

What's the secret? We can't get it working on Snes9x through the Wii Homebrew Channel... All help gratefully received! Cheers

EDITED: SOLVED! SEE MY OTHER POST BELOW

Edited by Kincl
Solved.

Share this post


Link to post
Share on other sites

Re my two posts above. I have solved the patched file size problem! You don't need to use lunar IPS or apply the patch yourself. All you have to do is put the Japanese ROM and the Beta version 7 patch into the ROM sub-folder of the snes9x folder on your SD card and make sure both the rom and the patch are called exactly the same thing but with the rom obviously ending .SMC or whatever and the patch ending .IPS. When you insert the SD card into the Wii the snes9x app on the HomeBrew Channel automatically applies the patch for you so that when you load up the ROM it plays with the Beta v7 patch applied, so in English etc. The massive benefit to this approach is that you never get the "invalid file size" notice because the ROM stays at about 4000 kilobytes and doesn't expand to 8000 kilobytes like it does when you apply the patch yourself through Lunar IPS on your PC.

 

Presumably this approach applies to the snes9x app in general, wherever you use it, not just when using the app on the Wii Homebrew Channel.

 

(If this has been at all helpful and you want to thank me and support the community, then please purchase a copy or two of the RPG fanzine I edit called HyperPlay RPG, available at hyperplayrpg.com !)

Edited by Kincl

Share this post


Link to post
Share on other sites
On 10/10/2017 at 10:14 PM, juicestand said:

Hello! I was wondering if anyone got this version patched and playable on the SNES Mini ?  I was able to get 1 version of the game uploaded but not this version. Thanks!

Install the RetroArch mod (look up a video on it) and it should work perfectly on the SNES Classic! Only thing that doesn't work is the rewind feature.

Share this post


Link to post
Share on other sites

Hi, I'm super noob at this emulator, ROM, patch, etc. stuff.

So, I got the snes9x emulator. I downloaded a ROM file for FE4. I downloaded the lunar IPS patch and patched the FE4 translator successfully. 

I get FE4 running on the emulator. The intro started and everything looked fine.

Once the intro music stops, the "New Game" tab pops up. I try clicking on it but nothing works. Press every single button on my keyboard but nothing happens. I cannot start a "new game" apparently.

Does this mean my ROM isn't a good file? What do I do? Delete it, find a new ROM? Did something go wrong in the patch process? Sorry I am pretty bad at this.

EDIT: Nevermind, got it working. Looks like I needed to fix the controls.

Also, is there any way to play with my mouse? Would much rather click and move with it than using the keyword. 

Edited by wtfamidoing

Share this post


Link to post
Share on other sites
On 11/14/2017 at 9:21 PM, wtfamidoing said:

Also, is there any way to play with my mouse? Would much rather click and move with it than using the keyword. 

Short of a LOT of hacking, no. This is a SNES game, after all, and they weren't controlled with a mouse.

 

In theory it would probably be possible to make the emulator treat the mouse as a super scope, and make the super scope be treated as the cursor location or something like that, but that sounds like a lot of effort and likely a lot of bugfixing too. So really, the answer is just... sorry, keyboard controls (or controller if you have one for your PC) is what you'll have to learn.

Share this post


Link to post
Share on other sites

Hi, I need help with something. Yesterday I did the prologue and saved, closed the emulator and the computer, but when today I opened it there wasn't any saved file, as if I had never played with it. Do you know how to fix it? Thanks

 

Share this post


Link to post
Share on other sites

I just finished playing FE4 on my PSP (connected to a TV) and I love this game! So many ideas and a large creative vision. I would like to say thanks to the translator.

The PSP Snes9x emulator has recently been updated to incorporate improvements made to the 3DS version, apparently, and so it ran the game just fine. The opening movie does have some slowdown, and spell effects outside of battle tend to drag a bit as well, but the game itself works just fine. You can find the new version here.

 

Share this post


Link to post
Share on other sites

Hello, I'm having an issue where saves with this patch will not load on BSNES Plus. This issue is exclusive to this patched version of the ROM, as it does not occur on any other ROMS. It is also exclusive to BSNES Plus as the issue does not occur when I load the game with SNES9X.  BSNES Plus still creates a save file, but the save file is blank. Save files created by SNES9X are not overwritten, but also fails to load.

Does anyone know what might be causing this issue?

Share this post


Link to post
Share on other sites
9 minutes ago, FEfan12 said:

Has anyone gotten this to work on Android phones?  Whenever I try to play the patched rom, it just shows a black screen.

Depends on your emulator, I’d presume. On SNES 9x EX+ it works well:

Screenshot_20171217_122134.png

Share this post


Link to post
Share on other sites

I'm using Snes 9x Ex+ with both IPS patches but the game still does not run.  It runs on my laptop though.  Did you transfer it to your phone after patching it on your computer?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...